summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Vihrov2015-06-14 10:30:46 +0300
committerAndrey Vihrov2015-06-14 10:30:46 +0300
commit0eed0411162774200f32a345cb510b699a8c9223 (patch)
treefc516ff035c3835b430bd4a726abcbffcc5f52cf
downloadaur-0eed0411162774200f32a345cb510b699a8c9223.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
-rw-r--r--mist-icon-theme.install24
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a3da9553203
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mist-icon-theme
+ pkgdesc = Mist icon theme
+ pkgver = 2.32.1
+ pkgrel = 4
+ url = https://wiki.gnome.org/GnomeArt
+ install = mist-icon-theme.install
+ arch = any
+ license = GPL
+ makedepends = intltool
+ makedepends = gtk-engines
+ makedepends = icon-naming-utils
+ depends = gtk-update-icon-cache
+ source = http://ftp.gnome.org/pub/GNOME/sources/gnome-themes/2.32/gnome-themes-2.32.1.tar.bz2
+ sha256sums = 8601ee24c2e096593221cbd6ebdb6686042225a03c02a01c0d67c163f9febd1a
+
+pkgname = mist-icon-theme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6e11842f6a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Andrey Vihrov <andrey.vihrov at gmail.com>
+# Contributor: TingPing <tingping@tingping.se>
+# Contributor: Jeremy Newton (Mystro256)
+
+pkgname=mist-icon-theme
+pkgver=2.32.1
+pkgrel=4
+pkgdesc="Mist icon theme"
+arch=('any')
+url="https://wiki.gnome.org/GnomeArt"
+license=('GPL')
+depends=('gtk-update-icon-cache')
+makedepends=('intltool' 'gtk-engines' 'icon-naming-utils')
+install="mist-icon-theme.install"
+source=("http://ftp.gnome.org/pub/GNOME/sources/gnome-themes/2.32/gnome-themes-$pkgver.tar.bz2")
+sha256sums=('8601ee24c2e096593221cbd6ebdb6686042225a03c02a01c0d67c163f9febd1a')
+
+build() {
+ cd "gnome-themes-$pkgver"
+
+ ./configure --prefix=/usr --disable-dependency-tracking
+ make -C icon-themes/Mist
+}
+
+package() {
+ cd "gnome-themes-$pkgver"
+
+ make DESTDIR="$pkgdir" -C icon-themes/Mist install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/mist-icon-theme.install b/mist-icon-theme.install
new file mode 100644
index 000000000000..12be2249c204
--- /dev/null
+++ b/mist-icon-theme.install
@@ -0,0 +1,24 @@
+ICONDIR="/usr/share/icons/Mist"
+
+update_icon_cache() {
+ echo "Updating GTK icon cache..." || return 1
+ gtk-update-icon-cache -f -t "${ICONDIR}" || return 1
+}
+
+
+# arg 1: the new package version
+post_install() {
+ update_icon_cache
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ update_icon_cache
+}
+
+# arg 1: the old package version
+post_remove() {
+ update_icon_cache
+ rmdir "${ICONDIR}"
+}