summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Vihrov2017-09-16 18:05:05 +0300
committerAndrey Vihrov2017-09-16 18:05:05 +0300
commit14d8920335e2dbc7b9fbd0f688505930a3e4c00c (patch)
treef253a2f26c6e00457eb6e452e4b9b93e925ad42f
parent8e1b95f2adf61ea7d973a47e9f72456a053c2a3b (diff)
downloadaur-14d8920335e2dbc7b9fbd0f688505930a3e4c00c.tar.gz
Update to latest git commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 24 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8721499ce121..104741f99d43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
# Generated by mksrcinfo v8
-# Wed Jan 4 21:01:56 UTC 2017
+# Sat Sep 16 15:03:46 UTC 2017
pkgbase = mist-icon-theme
pkgdesc = Mist icon theme
- pkgver = 2.32.1
- pkgrel = 6
+ pkgver = 3.0.0+20+gaaba3bb
+ pkgrel = 1
url = https://wiki.gnome.org/GnomeArt
arch = any
license = GPL
- makedepends = intltool
+ makedepends = git
makedepends = gtk-engines
makedepends = icon-naming-utils
+ makedepends = gnome-common
depends = gtk-update-icon-cache
- source = https://download.gnome.org/sources/gnome-themes/2.32/gnome-themes-2.32.1.tar.bz2
- source = eo.patch::https://git.gnome.org/browse/archive/gnome-themes/patch/?id=6404a664baa1bcb0ea7cb805470b9106d3f9ac75
- sha256sums = 8601ee24c2e096593221cbd6ebdb6686042225a03c02a01c0d67c163f9febd1a
- sha256sums = 40de2b4773a01d4aa7246924c951b844e74537f48f0996e306147dd255b84fde
+ source = git+https://git.gnome.org/browse/archive/gnome-themes#commit=aaba3bb83add369a480f393a8d0907f6ea72b285
+ sha256sums = SKIP
pkgname = mist-icon-theme
diff --git a/PKGBUILD b/PKGBUILD
index 54e684168fea..b0ef3a1f0297 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,34 +3,39 @@
# Contributor: Jeremy Newton (Mystro256)
pkgname=mist-icon-theme
-pkgver=2.32.1
-pkgrel=6
+pkgver=3.0.0+20+gaaba3bb
+pkgrel=1
pkgdesc="Mist icon theme"
arch=('any')
url="https://wiki.gnome.org/GnomeArt"
license=('GPL')
depends=('gtk-update-icon-cache')
-makedepends=('intltool' 'gtk-engines' 'icon-naming-utils')
-source=("https://download.gnome.org/sources/gnome-themes/${pkgver%.*}/gnome-themes-${pkgver}.tar.bz2"
- "eo.patch::https://git.gnome.org/browse/archive/gnome-themes/patch/?id=6404a664baa1bcb0ea7cb805470b9106d3f9ac75")
-sha256sums=('8601ee24c2e096593221cbd6ebdb6686042225a03c02a01c0d67c163f9febd1a'
- '40de2b4773a01d4aa7246924c951b844e74537f48f0996e306147dd255b84fde')
+makedepends=('git' 'gtk-engines' 'icon-naming-utils' 'gnome-common')
+_commit=aaba3bb83add369a480f393a8d0907f6ea72b285
+source=("git+https://git.gnome.org/browse/archive/gnome-themes#commit=${_commit}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "gnome-themes"
+ git describe --long | sed 's/GNOME_THEMES_//;s/_/./g;s/-/+/g'
+}
prepare() {
- cd "gnome-themes-${pkgver}"
+ cd "gnome-themes"
- patch -p1 < "${srcdir}/eo.patch"
+ # Revert 'Switch to GTK+ 3.0', it requires non-existent gtk-engines-3
+ git revert --no-commit 7c840124d0ed9e946fd7713f8a5761ea40a741f5
}
build() {
- cd "gnome-themes-${pkgver}"
+ cd "gnome-themes"
- ./configure --prefix=/usr --disable-dependency-tracking
+ ./autogen.sh --prefix=/usr --disable-dependency-tracking
make -C icon-themes/Mist
}
package() {
- cd "gnome-themes-${pkgver}"
+ cd "gnome-themes"
make DESTDIR="${pkgdir}" -C icon-themes/Mist install
}