summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Vihrov2015-08-13 20:00:08 +0300
committerAndrey Vihrov2015-08-13 20:00:08 +0300
commit8907f65941a4e4bb56d6bbb2f835882245750ce6 (patch)
treefc516ff035c3835b430bd4a726abcbffcc5f52cf
parentb5e466cfb4d7eb31e402e2e529470c3aff803fda (diff)
downloadaur-8907f65941a4e4bb56d6bbb2f835882245750ce6.tar.gz
Revert "Use xdg-icon-resource instead of gtk-update-icon-cache"
This reverts commit b5e466cfb4d7eb31e402e2e529470c3aff803fda. xdg-icon-resource has some problems, revert for now.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--mist-icon-theme.install20
3 files changed, 20 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 948006f938fc..8a3da9553203 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mist-icon-theme
pkgdesc = Mist icon theme
pkgver = 2.32.1
- pkgrel = 5
+ pkgrel = 4
url = https://wiki.gnome.org/GnomeArt
install = mist-icon-theme.install
arch = any
@@ -9,7 +9,7 @@ pkgbase = mist-icon-theme
makedepends = intltool
makedepends = gtk-engines
makedepends = icon-naming-utils
- depends = xdg-utils
+ depends = gtk-update-icon-cache
source = http://ftp.gnome.org/pub/GNOME/sources/gnome-themes/2.32/gnome-themes-2.32.1.tar.bz2
sha256sums = 8601ee24c2e096593221cbd6ebdb6686042225a03c02a01c0d67c163f9febd1a
diff --git a/PKGBUILD b/PKGBUILD
index 131ec7b1bc7e..b6e11842f6a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
pkgname=mist-icon-theme
pkgver=2.32.1
-pkgrel=5
+pkgrel=4
pkgdesc="Mist icon theme"
arch=('any')
url="https://wiki.gnome.org/GnomeArt"
license=('GPL')
-depends=('xdg-utils')
+depends=('gtk-update-icon-cache')
makedepends=('intltool' 'gtk-engines' 'icon-naming-utils')
install="mist-icon-theme.install"
source=("http://ftp.gnome.org/pub/GNOME/sources/gnome-themes/2.32/gnome-themes-$pkgver.tar.bz2")
diff --git a/mist-icon-theme.install b/mist-icon-theme.install
index 989465be5e5a..12be2249c204 100644
--- a/mist-icon-theme.install
+++ b/mist-icon-theme.install
@@ -1,12 +1,24 @@
+ICONDIR="/usr/share/icons/Mist"
+
+update_icon_cache() {
+ echo "Updating GTK icon cache..." || return 1
+ gtk-update-icon-cache -f -t "${ICONDIR}" || return 1
+}
+
+
+# arg 1: the new package version
post_install() {
- xdg-icon-resource forceupdate --theme Mist || return 1
+ update_icon_cache
}
+# arg 1: the new package version
+# arg 2: the old package version
post_upgrade() {
- post_install $1
+ update_icon_cache
}
+# arg 1: the old package version
post_remove() {
- post_install $1
- rmdir "/usr/share/icons/Mist"
+ update_icon_cache
+ rmdir "${ICONDIR}"
}