summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHendrik 'T4cC0re' Meyer2018-08-08 21:23:47 +0200
committerHendrik 'T4cC0re' Meyer2018-08-08 21:42:16 +0200
commit446708b5f392398d8c2fa18a2a1bd9ffa668af7c (patch)
treeb8c5fe8308a883d75dfb6f9a23a9e9c690a22b7e
downloadaur-mkinitcpio-mlx4.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--LICENSE14
-rw-r--r--PKGBUILD16
-rw-r--r--hook7
-rw-r--r--install12
5 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..455f2cb09a6a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mkinitcpio-mlx4
+ pkgdesc = Archlinux mkinitcpio hook to pack mlx4_core and mlx4_en kernel modules
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/t4cc0re/mkinitcpio-mlx4
+ arch = any
+ license = MIT
+ optdepends = mkinitcpio-netconf: Network interface configuration
+ source = hook
+ source = install
+ sha512sums = bcfa32d087c3de3c4c7e6396f2e96b30ac2d56e3cc50bd0dda4c170cefb6d4982005dcd193bf368f22bd0bc70d41fc06009cb7570d3e2d4371f9fd967f503e8b
+ sha512sums = 77161e19f5f150dd5a3f67b74a88b0eab3fe624924cdbc7894165c1108a593d584ca0512ed15eb513e00085b3d01ac763b3e25a23064133e3a972b2bdce5f9fb
+
+pkgname = mkinitcpio-mlx4
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..1140c9fd8147
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,14 @@
+Copyright 2018 Hendrik 'T4cC0re' Meyer
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated
+documentation files (the "Software"), to deal in the Software without restriction, including without limitation the
+rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to
+permit persons to whom the Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all copies or substantial portions of the
+Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE
+WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS
+OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR
+OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2d1e551366c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: Hendrik 'T4cC0re' Meyer <aur@t4cc0.re>
+pkgname=mkinitcpio-mlx4
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Archlinux mkinitcpio hook to pack mlx4_core and mlx4_en kernel modules"
+arch=('any')
+url="https://github.com/t4cc0re/mkinitcpio-mlx4"
+license=('MIT')
+optdepends=('mkinitcpio-netconf: Network interface configuration')
+source=('hook' 'install')
+sha512sums=('bcfa32d087c3de3c4c7e6396f2e96b30ac2d56e3cc50bd0dda4c170cefb6d4982005dcd193bf368f22bd0bc70d41fc06009cb7570d3e2d4371f9fd967f503e8b' '77161e19f5f150dd5a3f67b74a88b0eab3fe624924cdbc7894165c1108a593d584ca0512ed15eb513e00085b3d01ac763b3e25a23064133e3a972b2bdce5f9fb')
+
+package() {
+ install -Dm644 "$srcdir/hook" "$pkgdir/usr/lib/initcpio/hooks/mlx4"
+ install -Dm644 "$srcdir/install" "$pkgdir/usr/lib/initcpio/install/mlx4"
+}
diff --git a/hook b/hook
new file mode 100644
index 000000000000..7034f810dc54
--- /dev/null
+++ b/hook
@@ -0,0 +1,7 @@
+#!/usr/bin/ash
+
+run_hook () {
+}
+
+run_cleanuphook () {
+}
diff --git a/install b/install
new file mode 100644
index 000000000000..01441fa0d22b
--- /dev/null
+++ b/install
@@ -0,0 +1,12 @@
+#!/bin/bash
+
+build () {
+ add_module mlx4_core
+ add_module mlx4_en
+}
+
+help () {
+ cat << EOF
+This hook will just add mlx4_{core,en} modules to initrd. Useful to use Mellanox NICs with mkinitcpio-netconf.
+EOF
+}