summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrien Smith2019-04-21 19:07:22 -0600
committerAdrien Smith2019-04-21 19:07:22 -0600
commit25257c4b561a70b809e1b34012a8dc618e6f3d25 (patch)
treeac2b8a8df486f2df808643f5ec0a0dda5898f16d
parenta38923b948bca6e81e4ebedf58a8b524cf6ee479 (diff)
downloadaur-25257c4b561a70b809e1b34012a8dc618e6f3d25.tar.gz
Improve PKGBUILD, update changelog, support aarch64
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
-rw-r--r--mlat-client-git.changelog57
3 files changed, 67 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0bcd561842a..36ec96c9a2e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sat Apr 2 12:37:37 UTC 2016
pkgbase = mlat-client-git
pkgdesc = Mode S multilateration client. (by Mutability)
- pkgver = 0.2.4.r30.g5360df6
+ pkgver = 0.2.10.r0.g59e3d57
pkgrel = 1
url = https://github.com/mutability/mlat-client
changelog = mlat-client-git.changelog
@@ -10,9 +8,9 @@ pkgbase = mlat-client-git
arch = x86_64
arch = armv6h
arch = armv7h
+ arch = aarch64
license = GPL
makedepends = git
- makedepends = python
depends = python
provides = mlat-client
provides = fa-mlat-client
diff --git a/PKGBUILD b/PKGBUILD
index 2195e50acfb4..6076730fd7a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
-# Maintainer: Martin Poljak <martin at poljak dot cz>
+# Maintainer: Adrien Smith <adrien at bouldersmiths dot com>
+# Contributor: Martin Poljak <martin at poljak dot cz>
# Contributor: Dan Schaper <dschaper at ganymeade dot com>
pkgname=mlat-client-git
-pkgver=0.2.4.r30.g5360df6
+pkgver=0.2.10.r0.g59e3d57
pkgrel=1
pkgdesc="Mode S multilateration client. (by Mutability)"
-arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/mutability/mlat-client"
license=('GPL')
depends=('python')
-makedepends=('git' 'python')
-source=(${pkgname}::git://github.com/mutability/mlat-client.git)
+makedepends=('git')
+source=("${pkgname}::git://github.com/mutability/mlat-client.git")
md5sums=('SKIP')
changelog=$pkgname.changelog
provides=('mlat-client' 'fa-mlat-client')
conflicts=('mlat-client' 'fa-mlat-client')
pkgver() {
- cd ${pkgname}
+ cd "${pkgname}"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
@@ -32,4 +33,4 @@ package() {
install -Dm755 -t "${pkgdir}/usr/lib/piaware/helpers/" fa-mlat-client
install -Dm755 -t "${pkgdir}/usr/bin/" mlat-client
rm -f "${pkgdir}/usr/bin/fa-mlat-client"
-}
+}
diff --git a/mlat-client-git.changelog b/mlat-client-git.changelog
index 1c0b00ee00f5..7107801711fd 100644
--- a/mlat-client-git.changelog
+++ b/mlat-client-git.changelog
@@ -1,3 +1,60 @@
+mlat-client (0.2.10) stable; urgency=medium
+
+ * Fix handling of special (synthetic mlat / zero) message timestamps
+ * Fix handling of Radarcape UTC midnight timestamp rollover
+ * Fix typo in feet/meters conversion
+ * Increase listen queue size on listening output sockets
+ * Add a message timing correlation script
+
+ -- Oliver Jowett <oliver@mutability.co.uk> Thu, 02 Nov 2017 13:11:26 +0000
+
+mlat-client (0.2.9) stable; urgency=medium
+
+ * Fix jsonclient result path (github issue #18)
+
+ -- Oliver Jowett <oliver@mutability.co.uk> Mon, 03 Apr 2017 13:29:01 +0100
+
+mlat-client (0.2.8) stable; urgency=medium
+
+ * Mode A/C support
+ * DF18 trackfile identifier support for Mode A/C results
+ * Radarcape position message support
+ * Update Beast-format timestamp adjustments to match the behavior of
+ the Beast/Radarcape. This effectively only changes Mode A/C.
+
+ -- Oliver Jowett <oliver@mutability.co.uk> Mon, 16 Jan 2017 14:14:29 +0000
+
+mlat-client (0.2.7) stable; urgency=medium
+
+ * Add --no-anon-results option
+
+ -- Oliver Jowett <oliver@mutability.co.uk> Tue, 25 Oct 2016 23:42:40 +0100
+
+mlat-client (0.2.6) stable; urgency=medium
+
+ * Fix missing METH_KEYWORDS that would cause a crash on amd64
+ * Use sendto, not connect/send, for the UDP transport so that the
+ UDP source address follows any routing changes that happen
+
+ -- Oliver Jowett <oliver@mutability.co.uk> Wed, 27 Jul 2016 17:09:36 +0100
+
+mlat-client (0.2.5) stable; urgency=medium
+
+ * Overhaul of the extension module to allow much more filtering to happen
+ before messages are passed to the Python layer
+ * Autodetect input format where possible
+ * Generate results as DF18 TIS-B, not DF17
+ * Support generating DF18 "anonymous address" results
+ * Don't fail entirely if a result output listener can't be created
+ * IPv6 support
+ * Interpret Radarcape status messages and change clock mode based on GPS
+ status
+ * Send a settings message on Beast-format connections so that (if the
+ other end understands them) we get only the specific messages we care
+ about
+
+ -- Oliver Jowett <oliver@mutability.co.uk> Fri, 15 Jul 2016 13:13:03 +0100
+
mlat-client (0.2.4) unstable; urgency=medium
* Better periodic stats logging.