summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorevorster2021-05-18 20:04:06 +0200
committerevorster2021-05-18 20:04:06 +0200
commit0354a9095d1c553ee144fc16e1a80f0d4629fbd3 (patch)
treed852349ebe10bdf9b485fc8f018929ef82d5682b
parentb57395c87a6f1e880e94cf4e4ade07b85332d423 (diff)
downloadaur-0354a9095d1c553ee144fc16e1a80f0d4629fbd3.tar.gz
cmake build
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD117
2 files changed, 56 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f8777b348ca..ed2c73ec7daa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mlt-git
pkgdesc = Multimedia Framework
- pkgver = r1
+ pkgver = r5645.1621198199.afc1ae47
pkgrel = 1
url = https://github.com/mltframework/mlt
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 9e66d67d7711..f7a7f6452df0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,73 +1,66 @@
+# Maintainer nfnty <arch at nfnty dot se>
+# Maintainer evorster <evorster at gmail dot com>
+
pkgname=('mlt-git')
_srcname='mlt'
pkgdesc='Multimedia Framework'
-pkgver='r1'
-pkgrel='1'
+pkgver=r5645.1621198199.afc1ae47
+pkgrel=1
arch=('i686' 'x86_64')
-url="https://github.com/mltframework/${_srcname}"
-license=('GPL2')
+url="https://github.com/mltframework/${_srcname}" license=('GPL2')
+optdepends=( 'sdl_image: for SDL plugin'
+ 'libsamplerate: for libavresample plugin'
+ 'sox: for SOX (Audio Swiss Army Knife) plugin'
+ 'ffmpeg: for ffmpeg plugin'
+ 'vid.stab: for video stabilize plugin'
+ 'gtk2: Gtk plugin' 'qt5-svg: for Qt5 plugins'
+ 'jack: for JACK sound output plugin'
+ 'libexif: for auto rotate plugin'
+ 'frei0r-plugins: for additional effects'
+ 'movit: opengl plugin'
+ )
-optdepends=(
- 'sdl_image: for SDL plugin'
- 'libsamplerate: for libavresample plugin'
- 'sox: for SOX (Audio Swiss Army Knife) plugin'
- 'ffmpeg: for ffmpeg plugin'
- 'vid.stab: for video stabilize plugin'
- 'gtk2: Gtk plugin'
- 'qt5-svg: for Qt5 plugins'
- 'jack: for JACK sound output plugin'
- 'libexif: for auto rotate plugin'
- 'frei0r-plugins: for additional effects'
- 'movit: opengl plugin'
-)
-makedepends=(
- 'ladspa'
- 'frei0r-plugins'
- 'libdv'
- 'sdl_image'
- 'libsamplerate'
- 'sox'
- 'ffmpeg'
- 'vid.stab'
- 'qt5-svg'
- 'jack'
- 'libexif'
- 'python2'
- 'swig'
- 'git'
- 'movit'
-)
-provides=("${pkgname[0]%-git}")
-conflicts=("${pkgname[0]%-git}")
+makedepends=( 'ladspa'
+ 'frei0r-plugins'
+ 'libdv'
+ 'sdl_image'
+ 'libsamplerate'
+ 'sox'
+ 'ffmpeg'
+ 'vid.stab'
+ 'qt5-svg'
+ 'jack'
+ 'libexif'
+ 'python2'
+ 'swig'
+ 'git'
+ 'movit'
+ )
+provides=("${pkgname[0]%-git}") conflicts=("${pkgname[0]%-git}")
source=("${_srcname}::git+${url}.git")
sha512sums=('SKIP')
+pkgver(){ cd "${srcdir}/${_srcname}"
+ printf 'r%s.%s.%s\n' \
+ "$( git rev-list --count 'HEAD' )" \
+ "$( git log --max-count='1' --pretty='format:%ct' )" \
+ "$( git rev-parse --short 'HEAD' )"
+ }
-pkgver() {
- cd "${srcdir}/${_srcname}"
-
- printf 'r%s.%s.%s\n' \
- "$( git rev-list --count 'HEAD' )" \
- "$( git log --max-count='1' --pretty='format:%ct' )" \
- "$( git rev-parse --short 'HEAD' )"
-}
-
-build() {
- cd "${srcdir}/${_srcname}"
-
- ./configure \
- --prefix='/usr' \
- --avformat-swscale \
- --enable-gpl \
- --enable-gpl3 \
- --qt-libdir='/usr/lib' \
- --qt-includedir='/usr/include/qt'
-
- make
-}
+prepare(){ echo "Prepare"
+ }
-package() {
- cd "${srcdir}/${_srcname}"
+build(){ rm -rf build
+ mkdir -p build
+ cd build
+ cmake "../mlt"\
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DMOD_OPENCV=ON \
+ -DMOD_MOVIT=ON
+ make
+ }
- make DESTDIR="${pkgdir}" install
-}
+package(){ cd build
+ make DESTDIR="${pkgdir}" install
+ }