summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvert Vorster2023-01-08 09:08:08 +0200
committerEvert Vorster2023-01-08 09:08:08 +0200
commit9541f1504e62366dc23e7abed75b1b7f110350d5 (patch)
tree63af1bb35419f788e986f9cc23bad21e38798dfb
parent12550f5a0a8f7760e081989b308d77e9768f1b99 (diff)
downloadaur-9541f1504e62366dc23e7abed75b1b7f110350d5.tar.gz
Properly handle the glaxnimate submodule
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD29
2 files changed, 24 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1eee7ae0770..4e15257cf918 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -32,6 +32,8 @@ pkgbase = mlt-git
provides = mlt
conflicts = mlt
source = mlt::git+https://github.com/mltframework/mlt.git
+ source = git+https://gitlab.com/mattbas/glaxnimate.git
+ sha512sums = SKIP
sha512sums = SKIP
pkgname = mlt-git
diff --git a/PKGBUILD b/PKGBUILD
index 85774fb2ca5a..0fd4d4e7eb0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,10 @@
# Maintainer nfnty <arch at nfnty dot se>
# Maintainer evorster <evorster at gmail dot com>
-pkgname=('mlt-git')
+_gitname='mlt'
_srcname='mlt'
+pkgbase=$_gitname-git
+pkgname=('mlt-git')
pkgdesc='Multimedia Framework'
pkgver=r5946.1673114203.0b1d574c
pkgrel=1
@@ -36,21 +38,34 @@ makedepends=( 'ladspa'
)
provides=("${pkgname[0]%-git}") conflicts=("${pkgname[0]%-git}")
-source=( "${_srcname}::git+${url}.git"
+source=( "${_gitname}::git+${url}.git"
+ "git+https://gitlab.com/mattbas/glaxnimate.git"
)
-sha512sums=( 'SKIP'
+sha512sums=( 'SKIP' 'SKIP'
)
-pkgver(){ cd "${srcdir}/${_srcname}"
+pkgver(){ cd "${srcdir}/${_gitname}"
printf 'r%s.%s.%s\n' \
"$( git rev-list --count 'HEAD' )" \
"$( git log --max-count='1' --pretty='format:%ct' )" \
"$( git rev-parse --short 'HEAD' )"
}
-prepare(){ echo "Prepare"
- cd ${srcdir}/${_srcname}/src/modules/glaxnimate
+prepare(){ cd "${srcdir}/${_gitname}"
+
+ echo "Initialize Submodules"
git submodule init
- git submodule update
+
+ echo "Updating git submodule paths"
+ git config submodule.src/external/glaxnimate.url "$srcdir/glaxnimate"
+
+ echo "Updating git submodules"
+ git -c protocol.file.allow=always submodule update
+
+## Thanks to darling-git packager showing me how to do submodules.
+## There are some examples on how to deal with recursion in there too.
+# Old way of doing the submodule
+# cd ${srcdir}/${_gitname}/src/modules/glaxnimate
+# git submodule update
}
build(){ rm -rf build