summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonidas P2023-05-27 02:11:23 +0300
committerLeonidas P2023-05-27 02:11:23 +0300
commit3c6b96c1b06f72ec21aa44005d0eaf5ba3d1fd25 (patch)
tree446183e566a3983b16db4a9aeef823c7791dc26f
parent953f35827ad1e5255125032b3a66611da3dfbdb4 (diff)
downloadaur-mmc-utils-git.tar.gz
Upstream fixed. Remove CFLAGS patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
-rw-r--r--append-CFLAGS.patch13
3 files changed, 6 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a69047631dc..d7273dfa7c59 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mmc-utils-git
pkgdesc = Userspace tools for MMC/SD devices
- pkgver = r109.145c74a
- pkgrel = 1
+ pkgver = r113.9582278
+ pkgrel = 2
epoch = 1
url = https://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git
arch = x86_64
@@ -14,8 +14,6 @@ pkgbase = mmc-utils-git
provides = mmc-utils
conflicts = mmc-utils
source = git+https://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git
- source = append-CFLAGS.patch
sha256sums = SKIP
- sha256sums = 0ec2d5ed066dd0797b9d32fadea8c64e4fe509f3585cdbeeb3640c3a1cda9dfc
pkgname = mmc-utils-git
diff --git a/PKGBUILD b/PKGBUILD
index 3e38a4c38bc6..40c7b2a29247 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_pkgname=mmc-utils
pkgname=${_pkgname}-git
-pkgver=r109.145c74a
-pkgrel=1
+pkgver=r113.9582278
+pkgrel=2
epoch=1
pkgdesc="Userspace tools for MMC/SD devices"
arch=('x86_64' 'i686' 'aarch64' 'armv7h' 'armv6h')
@@ -13,25 +13,14 @@ license=('GPL')
makedepends=('git')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-source=(
- 'git+https://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git'
- 'append-CFLAGS.patch'
-)
-sha256sums=(
- 'SKIP'
- '0ec2d5ed066dd0797b9d32fadea8c64e4fe509f3585cdbeeb3640c3a1cda9dfc'
-)
+source=('git+https://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git')
+sha256sums=('SKIP')
pkgver() {
cd "${_pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "${_pkgname}"
- patch --forward --strip=1 --input="${srcdir}/append-CFLAGS.patch"
-}
-
build() {
cd "${_pkgname}"
make
diff --git a/append-CFLAGS.patch b/append-CFLAGS.patch
deleted file mode 100644
index e7903f168b41..000000000000
--- a/append-CFLAGS.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/Makefile b/Makefile
-index d8d59a4..9b413f9 100644
---- a/Makefile
-+++ b/Makefile
-@@ -1,7 +1,7 @@
- CC ?= gcc
- GIT_VERSION := "$(shell git describe --abbrev=6 --always --tags)"
- AM_CFLAGS = -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2
--CFLAGS ?= -g -O2 -DVERSION=\"$(GIT_VERSION)\"
-+CFLAGS += -g -O2 -DVERSION=\"$(GIT_VERSION)\"
- objects = \
- mmc.o \
- mmc_cmds.o \