summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlphaJack2021-09-26 22:00:02 +0200
committerAlphaJack2021-09-26 22:00:02 +0200
commitc1203ef9bf67a9e9aecd907504edd00d9c36fbc5 (patch)
tree5b22a1d32f6e7d3a7cfb341d01bd9698eb0ece1f
downloadaur-mnotify-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65eafb120e0e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mnotify-git
+ pkgdesc = A simple Matrix CLI client, primarily designed for sending notifications
+ pkgver = r44.95a4448
+ pkgrel = 1
+ url = https://codeberg.org/rumpelsepp/mnotify/
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ makedepends = go
+ makedepends = git
+ depends = libolm
+ source = git+https://codeberg.org/rumpelsepp/mnotify.git
+ sha256sums = SKIP
+
+pkgname = mnotify-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f87b42d1bb7a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: AlphaJack <alphajack at tuta dot io>
+
+pkgname="mnotify-git"
+pkgver=r44.95a4448
+pkgrel=1
+pkgdesc="A simple Matrix CLI client, primarily designed for sending notifications"
+url="https://codeberg.org/rumpelsepp/mnotify/"
+license=("GPL3")
+arch=("x86_64" "armv6h" "armv7h" "aarch64")
+depends=("libolm")
+makedepends=("go" "git")
+source=("git+https://codeberg.org/rumpelsepp/mnotify.git")
+sha256sums=("SKIP")
+
+pkgver(){
+ cd "mnotify"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build(){
+ cd "mnotify"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o mnotify .
+}
+
+package(){
+ cd "mnotify"
+ install -D -m 755 "mnotify" "$pkgdir/usr/bin/mnotify"
+}