summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaurens Hazewinkel2018-03-10 21:44:04 +0100
committerLaurens Hazewinkel2018-03-10 21:44:04 +0100
commitabbe86d9779e467c1d4bf67ec2cdcc845ca956bd (patch)
treee615b33a210b2afc18bb508ad6eb529aa6a7190a
downloadaur-mod-host.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
-rw-r--r--mod-host.patch41
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d91129a3d211
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mod-host
+ pkgdesc = LV2 host for Jack controllable via socket or command line
+ pkgver = 0.10.6
+ pkgrel = 1
+ url = https://github.com/moddevices/mod-host
+ arch = x86_64
+ license = GPL3
+ depends = lilv>=0.14.2
+ source = https://github.com/moddevices/mod-host/archive/v0.10.6.tar.gz
+ source = mod-host.patch
+ sha256sums = 58833f09cc3f1d632bcf288778e6eb48328c4cadf2027612ea4dc9a7748ecbb6
+ sha256sums = 9ab75f98304567a0adcc644b9f0ebf308ade7c617485164682d62297bd7dd8f8
+
+pkgname = mod-host
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45c6dd3b7985
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Laurens Hazewinkel <laurens dot hazewinkel at gmail dot com>
+pkgname=mod-host
+pkgver=0.10.6
+pkgrel=1
+pkgdesc="LV2 host for Jack controllable via socket or command line"
+arch=('x86_64')
+url="https://github.com/moddevices/mod-host"
+license=('GPL3')
+depends=('lilv>=0.14.2')
+source=("https://github.com/moddevices/mod-host/archive/v0.10.6.tar.gz"
+ "mod-host.patch")
+sha256sums=('58833f09cc3f1d632bcf288778e6eb48328c4cadf2027612ea4dc9a7748ecbb6'
+ '9ab75f98304567a0adcc644b9f0ebf308ade7c617485164682d62297bd7dd8f8')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ patch -p1 -i "${srcdir}/mod-host.patch"
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make PREFIX="/usr" DESTDIR="$pkgdir/" install
+}
diff --git a/mod-host.patch b/mod-host.patch
new file mode 100644
index 000000000000..825f2daa1d28
--- /dev/null
+++ b/mod-host.patch
@@ -0,0 +1,41 @@
+diff -ura mod-host-0.10.6/Makefile mod-host-0.10.6.new/Makefile
+--- mod-host-0.10.6/Makefile 2014-10-04 22:09:50.000000000 +0200
++++ mod-host-0.10.6.new/Makefile 2018-03-10 17:35:00.844263032 +0100
+@@ -53,7 +53,8 @@
+
+ # install rule
+ install: install_man
+- install $(PROG) $(BINDIR)
++ install -d $(DESTDIR)$(BINDIR)
++ install $(PROG) $(DESTDIR)$(BINDIR)
+
+ # clean rule
+ clean:
+@@ -67,7 +68,8 @@
+
+ # install manual page rule
+ install_man:
+- install doc/*.1 $(MANDIR)
++ install -d $(DESTDIR)$(MANDIR)
++ install doc/*.1 $(DESTDIR)$(MANDIR)
+
+ # generate the source file with the help message
+ A=`grep -n 'The commands supported' README.md | cut -d':' -f1`
+diff -ura mod-host-0.10.6/utils/txt2cvar.py mod-host-0.10.6.new/utils/txt2cvar.py
+--- mod-host-0.10.6/utils/txt2cvar.py 2014-10-04 22:09:50.000000000 +0200
++++ mod-host-0.10.6.new/utils/txt2cvar.py 2018-03-10 17:19:56.484289237 +0100
+@@ -3,7 +3,7 @@
+ import sys, os
+
+ if len(sys.argv) < 2:
+- print 'Usage:', sys.argv[0], '<file_path> [var_name]'
++ print ('Usage:', sys.argv[0], '<file_path> [var_name]')
+ exit(1)
+
+ f = open(sys.argv[1])
+@@ -23,4 +23,4 @@
+ output += '\n'
+
+ output += '0x00\n};'
+-print output
++print(output)