summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntti Ellilä2024-05-01 20:01:47 +0300
committerAntti Ellilä2024-05-01 20:01:47 +0300
commit41b72d97a2e7a08276da885849f2b906d60bfddc (patch)
treec2e4516babd3db7e6ffc0da5204670d65cc3f1af
parentb61438485ec6eba1f5d17abc712b46dfa04e0998 (diff)
downloadaur-modrinth-app.tar.gz
export cargo target dir
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0953501ac7d..0f969f141158 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = modrinth-app
pkgdesc = An unique, open source launcher that allows you to play your favorite mods, and keep them up to date, all in one neat little package.
pkgver = 0.7.1
- pkgrel = 1
+ pkgrel = 2
url = https://modrinth.com/app
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index aed2ef9f2e6e..3b14d06019da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=modrinth-app
pkgver=0.7.1
-pkgrel=1
+pkgrel=2
pkgdesc='An unique, open source launcher that allows you to play your favorite mods, and keep them up to date, all in one neat little package.'
url='https://modrinth.com/app'
arch=('x86_64')
@@ -30,6 +30,7 @@ options=('!lto')
prepare() {
cd "theseus-${pkgver}"
+ export CARGO_TARGET_DIR=target
export RUSTUP_TOOLCHAIN=stable
cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
@@ -44,6 +45,7 @@ build() {
cd ..
+ export CARGO_TARGET_DIR=target
export RUSTUP_TOOLCHAIN=stable
cargo build --frozen --release --all-features
}
@@ -51,6 +53,7 @@ build() {
check() {
cd "theseus-${pkgver}"
+ export CARGO_TARGET_DIR=target
export RUSTUP_TOOLCHAIN=stable
cargo test --frozen --all-features
}