summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÉtienne Deparis2018-11-05 11:59:36 +0100
committerÉtienne Deparis2018-11-05 11:59:36 +0100
commit44b3aed0591b3edaf805a11b79bfe179236eb532 (patch)
tree206e10f4c7f35b84604e9ba7783935a197dfc5c0
parent3d527046c10504b0a5eea250d5efa18c6fd8157f (diff)
downloadaur-44b3aed0591b3edaf805a11b79bfe179236eb532.tar.gz
3.0.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD26
-rw-r--r--molotov2
3 files changed, 19 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f4f236b0f0d..a990b0fcfa39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by makepkg 5.1.1
-# Wed Sep 5 19:04:07 UTC 2018
+# Mon Nov 5 10:58:25 UTC 2018
pkgbase = molotov
pkgdesc = Streaming access to French (only) TV channels.
- pkgver = 2.3.0
+ pkgver = 3.0.0
pkgrel = 1
url = http://www.molotov.tv/
arch = i686
@@ -14,10 +14,10 @@ pkgbase = molotov
depends = desktop-file-utils
depends = xdg-utils
options = !strip
- source = Molotov-2.3.0.AppImage::http://desktop-auto-upgrade.molotov.tv/linux/2.3.0/molotov.AppImage
+ source = Molotov-3.0.0.AppImage::http://desktop-auto-upgrade.molotov.tv/linux/3.0.0/molotov.AppImage
source = molotov
- sha256sums = 07cfca0bd85f11d8565a5b0f2fa5a49d3a57d976ba55cc6944d92324aa061840
- sha256sums = 2be51f427383ccf086485dc49f5d93855550598371b5ea9e583d4a7d6726534e
+ sha256sums = 36c3d7466c6fe2ce3b10d4e73091bd1cd9810b0c91331efb4d7ae0427267f9fa
+ sha256sums = 3a2d0c45ec2a964b229ee44a729d5d86319d573296ca44c8a33e171ce23a3b47
pkgname = molotov
diff --git a/PKGBUILD b/PKGBUILD
index af68b1d32cf9..acaa0f0379b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Étienne Deparis <etienne@depar.is>
pkgname=molotov
-pkgver=2.3.0
+pkgver=3.0.0
pkgrel=1
pkgdesc="Streaming access to French (only) TV channels."
arch=('i686' 'x86_64')
@@ -12,19 +12,19 @@ makedepends=('p7zip')
options=('!strip')
source=("Molotov-${pkgver}.AppImage::http://desktop-auto-upgrade.molotov.tv/linux/${pkgver}/$pkgname.AppImage"
'molotov')
-sha256sums=('07cfca0bd85f11d8565a5b0f2fa5a49d3a57d976ba55cc6944d92324aa061840'
- '2be51f427383ccf086485dc49f5d93855550598371b5ea9e583d4a7d6726534e')
+sha256sums=('36c3d7466c6fe2ce3b10d4e73091bd1cd9810b0c91331efb4d7ae0427267f9fa'
+ '3a2d0c45ec2a964b229ee44a729d5d86319d573296ca44c8a33e171ce23a3b47')
prepare() {
cd $srcdir
- # Avoid cleaning error when attempting a makepkg --nobuild -c
- chmod 755 usr/share/icons
+ chmod u+x Molotov-${pkgver}.AppImage
+ ./Molotov-${pkgver}.AppImage --appimage-extract 2> /dev/null
}
build() {
cd $srcdir
- sed -i "s/Exec=AppRun/Exec=$pkgname/" Molotov.desktop
- sed -i "s/Categories=AudioVideo/Categories=Video;Player;AudioVideo;/" Molotov.desktop
+ sed -i "s/Exec=AppRun/Exec=$pkgname/" squashfs-root/molotov.desktop
+ sed -i "s/Categories=AudioVideo/Categories=Video;Player;AudioVideo;/" squashfs-root/molotov.desktop
sed -i "s/MOLOTOV_VERSION/${pkgver}/g" molotov
}
@@ -37,13 +37,13 @@ package() {
# TODO find a decent license
#install -d -m755 $pkgdir/usr/share/licenses/$pkgname
- for icon_dir in usr/share/icons/default/*; do
- size=$(basename $icon_dir)
- install -d -m755 $pkgdir/usr/share/icons/hicolor/$size/apps
- install -D -m644 $icon_dir/apps/Molotov.png $pkgdir/usr/share/icons/hicolor/$size/apps/Molotov.png
- done
+ # Only one icon left :/
+ install -d -m755 $pkgdir/usr/share/icons/hicolor/256x256/apps
+ icon_dir=squashfs-root/usr/share/icons/hicolor/0x0
+ install -D -m644 $icon_dir/apps/molotov.png $pkgdir/usr/share/icons/hicolor/256x256/apps/molotov.png
- install -D -m644 Molotov.desktop $pkgdir/usr/share/applications/appimagekit-Molotov.desktop
+ install -D -m644 squashfs-root/molotov.desktop $pkgdir/usr/share/applications/appimagekit-molotov.desktop
install -D -m755 molotov $pkgdir/usr/bin/molotov
install -D -m755 Molotov-$pkgver.AppImage $pkgdir/opt/appimages/Molotov-$pkgver.AppImage
+ rm -r squashfs-root
}
diff --git a/molotov b/molotov
index c35aeb3100a8..b362c18e7021 100644
--- a/molotov
+++ b/molotov
@@ -1,5 +1,5 @@
#!/usr/bin/env bash
[ -z "$XDG_DATA_DIRS" ] && export XDG_DATA_DIRS=$HOME/.local/share:/usr/share
-export SKIP=yes
+export APPIMAGE_SILENT_INSTALL=yes
exec /opt/appimages/Molotov-MOLOTOV_VERSION.AppImage