summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranonimal2018-10-13 22:07:15 +0000
committeranonimal2018-10-13 22:09:58 +0000
commit6ce2dffc1afc8dcce6f9f8b8cbbd2dfa7bcf4410 (patch)
treea4805e310cdfc6dc26efe250e060699fb5063eee
parentc7dfb2eb3f65d25847b9bef11981062f0c3f5605 (diff)
downloadaur-6ce2dffc1afc8dcce6f9f8b8cbbd2dfa7bcf4410.tar.gz
PKGBUILD: disable building/running of tests
Tests should not be needed outside of the development environment. Cherry-picking tests that aren't "too long" also defeats the purpose of running tests.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD30
2 files changed, 18 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb50c7d45fa9..eaa3c6d0ad5c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Oct 13 22:06:24 UTC 2018
+# Sat Oct 13 22:09:31 UTC 2018
pkgbase = monero
pkgdesc = Monero: the secure, private, untraceable currency - release version (includes daemon, wallet and miner)
pkgver = 0.13.0.2
- pkgrel = 1
+ pkgrel = 2
url = https://getmonero.org/
arch = x86_64
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index d191c2df28ad..8d5791d3cdc7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgbase=('monero')
pkgname=('monero' 'libmonero-wallet')
pkgver=0.13.0.2
-pkgrel=1
+pkgrel=2
pkgdesc="Monero: the secure, private, untraceable currency - release version (includes daemon, wallet and miner)"
license=('custom:Cryptonote')
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
@@ -39,19 +39,21 @@ build() {
make
}
-check() {
- cd "${srcdir}/${_monero}/${_build}"
-
- # Temporarily disable some a tests:
- # * coretests takes too long (~25000s)
- # * libwallet_api_tests fail (Issue #895)
- # * unit_tests were run separately above
- # * hash-variant2-int-sqrt takes too long
- CTEST_ARGS+="-E 'core_tests|libwallet_api_tests|unit_tests|hash-variant2-int-sqrt'"
- echo ">>> NOTE: some tests excluded: $CTEST_ARGS"
-
- make ARGS="$CTEST_ARGS" test
-}
+# Disable running of tests. Tests should not be needed outside of the development environment.
+# Cherry-picking tests that aren't "too long" also defeats the purpose of running tests.
+#check() {
+# cd "${srcdir}/${_monero}/${_build}"
+#
+# # Temporarily disable some a tests:
+# # * coretests takes too long (~25000s)
+# # * libwallet_api_tests fail (Issue #895)
+# # * unit_tests were run separately above
+# # * hash-variant2-int-sqrt takes too long
+# CTEST_ARGS+="-E 'core_tests|libwallet_api_tests|unit_tests|hash-variant2-int-sqrt'"
+# echo ">>> NOTE: some tests excluded: $CTEST_ARGS"
+#
+# make ARGS="$CTEST_ARGS" test
+#}
package_monero() {
backup=('etc/monerod.conf')