summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranonimal2016-09-21 06:19:24 +0000
committeranonimal2016-09-21 06:19:24 +0000
commit9d188f402fc352d90843c7b86f964378f3929aec (patch)
treec223eaff811ec2c1d68b7bad947d32a301138e05
parent4352c35ebeea99bce5e770c1d069ced1e21507eb (diff)
downloadaur-9d188f402fc352d90843c7b86f964378f3929aec.tar.gz
v0.10.0: initial fork from bitmonero-git
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD168
-rw-r--r--monero.install33
3 files changed, 108 insertions, 124 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23ae73e5fcc9..882e40d88573 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
# Generated by mksrcinfo v8
-# Wed Sep 21 02:51:09 UTC 2016
-pkgbase = bitmonero-git
- pkgdesc = Peer-to-peer network based anonymous digital currency (includes deaemon, wallet and miner)
+# Wed Sep 21 06:18:20 UTC 2016
+pkgbase = monero
+ pkgdesc = Monero: the secure, private, untraceable currency - release version (includes deaemon, wallet and miner)
pkgver = 0.10.0
pkgrel = 1
url = https://getmonero.org/
@@ -12,29 +12,26 @@ pkgbase = bitmonero-git
makedepends = git
makedepends = cmake
makedepends = boost
- makedepends = gtest
- depends = boost-libs>=1.45
+ depends = boost-libs>=1.58
depends = unbound>=1.4.16
depends = miniupnpc>=1.6
depends = libunwind
depends = openssl
- source = monero::git+https://github.com/monero-project/monero.git
+ provides = monero
+ provides = libmonero-wallet
+ conflicts = bitmonero-git
+ conflicts = libmonero-wallet-git
+ source = https://github.com/monero-project/monero/archive/v0.10.0.tar.gz
source = monerod.service
source = monerod.conf
- md5sums = SKIP
- md5sums = 978b5dda921ad298d93eaf701094f835
- md5sums = 7115d61857ce249a3e9ccf2c6bc4f00b
+ sha256sums = c6c186267b45dae62196e7904c3983adaa4f791784ee11baa13054d5bdfc5d9b
+ sha256sums = 71214c939e0d9b1097d04603caf0294aabcff2a4019d16b44aadfb3af6462a17
+ sha256sums = 829445fe9acc00681f94f7b9ca6ce39713e377970b0a3d6f88c37991e1aa61b2
-pkgname = bitmonero-git
+pkgname = monero
install = monero.install
- provides = bitmonero
- conflicts = bitmonero
backup = etc/monerod.conf
-pkgname = libmonero-wallet-git
- provides = libmonero-wallet
- provides = libmonerowallet-git
- conflicts = libmonero-wallet
- conflicts = libmonerowallet-git
+pkgname = libmonero-wallet
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index 109304003514..3d73ed6f53d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,116 +1,106 @@
-# Maintainer: Onishin <onishin at onishin dot org>
-# Co-maintainer: redfish <redfish at galactica dot pw>
+# Maintainer: anonimal <anonimal at i2pmail dot org>
+# Contributor: redfish <redfish at galactica dot pw>
+# Contributor: Onishin <onishin at onishin dot org>
-# TODO: rename package to monero-git in a few weeks
-pkgbase=('bitmonero-git')
-pkgname=('bitmonero-git' 'libmonero-wallet-git')
-_gitname='monero'
+pkgbase=('monero')
+pkgname=('monero' 'libmonero-wallet')
pkgver=0.10.0
pkgrel=1
+pkgdesc="Monero: the secure, private, untraceable currency - release version (includes deaemon, wallet and miner)"
+license=('custom:Cryptonote')
arch=('x86_64' 'i686' 'armv7h')
url="https://getmonero.org/"
-license=('custom:Cryptonote')
-
-depends=('boost-libs>=1.45' 'unbound>=1.4.16' 'miniupnpc>=1.6' 'libunwind' 'openssl')
-makedepends=('git' 'cmake' 'boost' 'gtest')
+depends=('boost-libs>=1.58' 'unbound>=1.4.16' 'miniupnpc>=1.6' 'libunwind' 'openssl')
+makedepends=('git' 'cmake' 'boost') #'gtest' # TODO(anonimal): Uncomment when tests are fixed
+provides=('monero' 'libmonero-wallet')
+conflicts=('bitmonero-git' 'libmonero-wallet-git')
+# TODO(anonimal): Uncomment when tests are fixed
+BUILDENV+=('!check')
-pkgdesc="Peer-to-peer network based anonymous digital currency (includes deaemon, wallet and miner)"
-source=("$_gitname::git+https://github.com/monero-project/monero.git"
+source=("https://github.com/monero-project/monero/archive/v${pkgver}.tar.gz"
"monerod.service"
- "monerod.conf"
-)
-
-md5sums=('SKIP'
- '978b5dda921ad298d93eaf701094f835'
- '7115d61857ce249a3e9ccf2c6bc4f00b')
-
-_builddir=build
-
-pkgver() {
- cd "$srcdir/$_gitname"
- git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
+ "monerod.conf")
+
+sha256sums+=('c6c186267b45dae62196e7904c3983adaa4f791784ee11baa13054d5bdfc5d9b'
+ '71214c939e0d9b1097d04603caf0294aabcff2a4019d16b44aadfb3af6462a17'
+ '829445fe9acc00681f94f7b9ca6ce39713e377970b0a3d6f88c37991e1aa61b2')
+
+_monero="${pkgbase}-${pkgver}"
+_build=build
build() {
- cd "$srcdir/$_gitname"
-
- if check_option "debug" "y"
- then
- _buildtype="Debug"
- else
- _buildtype+="Release"
- fi
-
- CMAKE_FLAGS+=" -DCMAKE_BUILD_TYPE=$_buildtype "
- CMAKE_FLAGS+=" -DCMAKE_INSTALL_PREFIX=/usr "
- CMAKE_FLAGS+=" -DBUILD_TESTS=ON "
- CMAKE_FLAGS+=" -DBUILD_GUI_DEPS=ON "
- CMAKE_FLAGS+=" -Wno-dev " # silence warnings for devs
- CMAKE_FLAGS+=" -DCMAKE_LINKER=/usr/bin/ld.gold " # #974 ld segfault on ARM
-
- mkdir -p $_builddir && cd $_builddir
- cmake $CMAKE_FLAGS ..
- make
+ cd "${srcdir}/${_monero}"
+ if check_option "debug" "y"
+ then
+ _build_type="Debug"
+ else
+ _build_type+="Release"
+ fi
+ CMAKE_FLAGS+=" -DCMAKE_BUILD_TYPE=$_build_type "
+ CMAKE_FLAGS+=" -DCMAKE_INSTALL_PREFIX=/usr "
+ #CMAKE_FLAGS+=" -DBUILD_TESTS=ON " # TODO(anonimal): Uncomment when tests are fixed
+ CMAKE_FLAGS+=" -DBUILD_GUI_DEPS=ON "
+ CMAKE_FLAGS+=" -Wno-dev " # silence warnings for devs
+ CMAKE_FLAGS+=" -DCMAKE_LINKER=/usr/bin/ld.gold " # #974 ld segfault on ARM
+ mkdir -p $_build && cd $_build
+ cmake $CMAKE_FLAGS ../
+ make
}
check() {
- cd "$srcdir/$_gitname"
- cd build
-
- # Run unit_tests test separately to exclude DNS tests which often fail with
- # DNS nameservers configured on some systems
- EXCLUDED_UNIT_TESTS+='DNSResolver.IPv4Failure'
- EXCLUDED_UNIT_TESTS+=':DNSResolver.DNSSECSuccess'
- EXCLUDED_UNIT_TESTS+=':AddressFromURL.Failure'
- tests/unit_tests/unit_tests --gtest_filter="-$EXCLUDED_UNIT_TESTS"
-
- # Temporarily disable some a tests:
- # * coretests takes too long (~25000s)
- # * libwallet_api_tests fail (Issue #895)
- # * unit_tests were run separately above
- CTEST_ARGS+="-E 'coretests|libwallet_api_tests|unit_tests'"
- echo ">>> NOTE: some tests excluded: $CTEST_ARGS"
-
- make ARGS="$CTEST_ARGS" test
+ cd "$srcdir/$_monero"
+ cd build
+
+ # Run unit_tests test separately to exclude DNS tests which often fail with
+ # DNS nameservers configured on some systems
+ EXCLUDED_UNIT_TESTS+='DNSResolver.IPv4Failure'
+ EXCLUDED_UNIT_TESTS+=':DNSResolver.DNSSECSuccess'
+ EXCLUDED_UNIT_TESTS+=':AddressFromURL.Failure'
+ tests/unit_tests/unit_tests --gtest_filter="-$EXCLUDED_UNIT_TESTS"
+
+ # Temporarily disable some a tests:
+ # * coretests takes too long (~25000s)
+ # * libwallet_api_tests fail (Issue #895)
+ # * unit_tests were run separately above
+ CTEST_ARGS+="-E 'coretests|libwallet_api_tests|unit_tests'"
+ echo ">>> NOTE: some tests excluded: $CTEST_ARGS"
+
+ make ARGS="$CTEST_ARGS" test
}
-package_bitmonero-git() {
+package_monero() {
+ backup=('etc/monerod.conf')
+ install=monero.install
- provides=('bitmonero')
- conflicts=('bitmonero')
+ # Uncomment for a debug build
+ # options=(!strip debug)
- backup=('etc/monerod.conf')
- install=monero.install
+ install -Dm755 "${srcdir}/${_monero}/build/bin/monerod" "${pkgdir}/usr/bin/monerod"
+ install -Dm755 "${srcdir}/${_monero}/build/bin/monero-wallet-cli" "${pkgdir}/usr/bin/monero-wallet-cli"
+ install -Dm755 "${srcdir}/${_monero}/build/bin/monero-blockchain-import" "${pkgdir}/usr/bin/monero-blockchain-import"
+ install -Dm755 "${srcdir}/${_monero}/build/bin/monero-blockchain-export" "${pkgdir}/usr/bin/monero-blockchain-export"
- # Uncomment for a debug build
- # options=(!strip debug)
+ install -Dm644 "${srcdir}/${_monero}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -D -m755 "$srcdir/$_gitname/build/bin/monerod" "$pkgdir/usr/bin/monerod"
- install -D -m755 "$srcdir/$_gitname/build/bin/monero-wallet-cli" "$pkgdir/usr/bin/monero-wallet-cli"
- install -D -m755 "$srcdir/$_gitname/build/bin/monero-blockchain-import" "$pkgdir/usr/bin/monero-blockchain-import"
- install -D -m755 "$srcdir/$_gitname/build/bin/monero-blockchain-export" "$pkgdir/usr/bin/monero-blockchain-export"
+ install -Dm644 "${srcdir}/monerod.conf" "${pkgdir}/etc/monerod.conf"
+ install -Dm644 "${srcdir}/monerod.service" "${pkgdir}/usr/lib/systemd/system/monerod.service"
- install -Dm644 $srcdir/monerod.service "${pkgdir}/usr/lib/systemd/system/monerod.service"
- install -Dm644 "$srcdir/monerod.conf" "$pkgdir/etc/monerod.conf"
- install -D -m644 "$srcdir/$_gitname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-package_libmonero-wallet-git() {
+package_libmonero-wallet() {
+ # NOTE: this is crucial, otherwise stripping breaks the .a archive:
+ # monero-core (GUI) fails to link against it (it can't find symbols
+ # that are clearly in the library).
+ options=(!strip)
- provides=('libmonero-wallet' 'libmonerowallet-git')
- conflicts=('libmonero-wallet' 'libmonerowallet-git')
+ _stage_dir=stagedir
- # NOTE: this is crucial, otherwise stripping breaks the .a archive:
- # monero-core (GUI) fails to link against it (it can't find symbols
- # that are clearly in the library).
- options=(!strip)
+ cd "${srcdir}/${_monero}/${_build}"
- cd $srcdir/$_gitname/$_builddir
- _stagedir=stagedir
- mkdir -p $_stagedir
- make DESTDIR=$_stagedir install
+ mkdir -p $_stage_dir
+ make DESTDIR=$_stage_dir install
- cd $_stagedir
- find usr/{include,lib} -type f -exec install -D -m 755 {} ${pkgdir}/{} \;
+ cd $_stage_dir
+ find usr/{include,lib} -type f -exec install -D -m 755 {} ${pkgdir}/{} \;
}
diff --git a/monero.install b/monero.install
index c63e0f049508..1517ca0e2f32 100644
--- a/monero.install
+++ b/monero.install
@@ -1,26 +1,23 @@
create_user() {
- getent passwd monero &>/dev/null || {
- echo -n ">>> Creating monero user... "
- useradd --system --user-group -m --home /var/lib/monero monero
- echo "done"
- } # NOTE: we do not autoremove user due to security concerns (Arch policy)
-
- mkdir -p /var/log/monero && chown monero:monero /var/log/monero
+ getent passwd monero &>/dev/null || {
+ echo -n ">>> Creating monero user... "
+ useradd --system --user-group -m --home /var/lib/monero monero
+ echo "done"
+ } # NOTE: we do not autoremove user due to security concerns (Arch policy)
+ mkdir -p /var/log/monero && chown monero:monero /var/log/monero
}
post_install() {
- create_user
+ create_user
}
post_upgrade() {
- create_user
-
- echo ">>> NOTICE: Package changed location of data dir (again! rebranding)."
- echo ">>> Please move your monero data dir to new location "
- echo ">>> before starting daemon systemd service:"
- echo ">>> sudo mv /var/lib/bitmonero /var/lib/monero/"
- echo ">>> sudo chown -R monero:monero /var/lib/monero/"
-
- echo ">>> NOTICE: Soon, this package will be renamed to 'monero-git':"
- echo ">>> this package will be deprecated and a new package will be created."
+ create_user
+ echo ">>> IMPORANT NOTICE:"
+ echo ">>> If you were previously using bitmonero-git, please perform"
+ echo ">>> the following before starting monerod or monerod systemd unit:"
+ echo ""
+ echo "$ sudo mv /var/lib/bitmonero /var/lib/monero/"
+ echo "$ sudo chown -R monero:monero /var/lib/monero/"
+ echo ""
}