summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranonimal2017-10-30 13:23:34 +0000
committeranonimal2017-10-30 13:28:18 +0000
commitec2b529b237b5823ff7443ad43ef510196004d2f (patch)
treed6bcf0382779d0922458541966f76afc8f46daa7
parent7849132d041e4bf0af6ecd819da88eec01570901 (diff)
downloadaur-ec2b529b237b5823ff7443ad43ef510196004d2f.tar.gz
v0.11.1.0: reintroduce master branch service file
Monero had always used one branch (master) for the v0.10.0 series. Only in v0.11.0 are we now seeing more than one branch again. This working service file should've been merged into the v0.11.0 series before release (and I had been almost certain they made the merge in v0.11.1.0)
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--monerod.service18
3 files changed, 31 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e789fcfc1081..6dd65b731430 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Oct 25 14:17:43 UTC 2017
+# Mon Oct 30 13:28:08 UTC 2017
pkgbase = monero
pkgdesc = Monero: the secure, private, untraceable currency - release version (includes daemon, wallet and miner)
pkgver = 0.11.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://getmonero.org/
arch = x86_64
arch = i686
@@ -24,7 +24,9 @@ pkgbase = monero
conflicts = bitmonero-git
conflicts = libmonero-wallet-git
source = https://github.com/monero-project/monero/archive/v0.11.1.0.tar.gz
+ source = monerod.service
sha256sums = b5b48d3e5317c599e1499278580e9a6ba3afc3536f4064fcf7b20840066a509b
+ sha256sums = 59fc670cf92960832d03038968270f81beacea7d6819c71ec5bcf15c6030e3c9
pkgname = monero
install = monero.install
diff --git a/PKGBUILD b/PKGBUILD
index 52cb35b4850b..3b70f1b246c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgbase=('monero')
pkgname=('monero' 'libmonero-wallet')
pkgver=0.11.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Monero: the secure, private, untraceable currency - release version (includes daemon, wallet and miner)"
license=('custom:Cryptonote')
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
@@ -15,8 +15,11 @@ makedepends=('git' 'cmake' 'boost' 'gtest')
provides=('monero' 'libmonero-wallet')
conflicts=('bitmonero-git' 'libmonero-wallet-git')
-source=("https://github.com/monero-project/monero/archive/v${pkgver}.tar.gz")
-sha256sums+=('b5b48d3e5317c599e1499278580e9a6ba3afc3536f4064fcf7b20840066a509b')
+source=("https://github.com/monero-project/monero/archive/v${pkgver}.tar.gz"
+ "monerod.service")
+
+sha256sums+=('b5b48d3e5317c599e1499278580e9a6ba3afc3536f4064fcf7b20840066a509b'
+ '59fc670cf92960832d03038968270f81beacea7d6819c71ec5bcf15c6030e3c9')
_monero="${pkgbase}-${pkgver}"
_build=build
@@ -69,7 +72,9 @@ package_monero() {
install -Dm644 "${srcdir}/${_monero}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm644 "${srcdir}/${_monero}/utils/conf/monerod.conf" "${pkgdir}/etc/monerod.conf"
- install -Dm644 "${srcdir}/${_monero}/utils/systemd/monerod.service" "${pkgdir}/usr/lib/systemd/system/monerod.service"
+ # TODO(anonimal): new, working, systemd service file was not merged into monero branch v0.11.1.0 - so we've git-add'd it ourselves
+ #install -Dm644 "${srcdir}/${_monero}/utils/systemd/monerod.service" "${pkgdir}/usr/lib/systemd/system/monerod.service"
+ install -Dm644 "${srcdir}/monerod.service" "${pkgdir}/usr/lib/systemd/system/monerod.service"
}
diff --git a/monerod.service b/monerod.service
new file mode 100644
index 000000000000..96e88a2d30b5
--- /dev/null
+++ b/monerod.service
@@ -0,0 +1,18 @@
+[Unit]
+Description=Monero Full Node
+After=network.target
+
+[Service]
+User=monero
+Group=monero
+WorkingDirectory=~
+RuntimeDirectory=monero
+
+Type=forking
+PIDFile=/run/monero/monerod.pid
+
+ExecStart=/usr/bin/monerod --config-file /etc/monerod.conf \
+ --detach --pidfile /run/monero/monerod.pid
+
+[Install]
+WantedBy=multi-user.target