summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2018-07-21 22:15:18 -0400
committerredfish2018-07-21 22:16:09 -0400
commit0436507349bb0461e62dde4b3467e90df5060b8d (patch)
tree8835981d9387f397218c15de67ce91e87a033e48
parent80aa9696a235a7e0c7c67bb715b5476db078445a (diff)
downloadaur-0436507349bb0461e62dde4b3467e90df5060b8d.tar.gz
update to 0.12.3.0
unbound and miniupnpc are now unconditionally vendored. Remove openssl 1.0 option, nobody should be building with it.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD27
2 files changed, 14 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27cf801ade56..3376f714fea0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Apr 28 20:27:36 UTC 2018
+# Sun Jul 22 02:15:09 UTC 2018
pkgbase = monero-git
pkgdesc = Peer-to-peer anonymous digital currency (daemon, CLI wallet, and wallet API library)
- pkgver = 0.12.0.0
+ pkgver = 0.12.3.0
pkgrel = 1
url = https://getmonero.org/
arch = x86_64
@@ -16,12 +16,11 @@ pkgbase = monero-git
makedepends = gtest
makedepends = qt5-tools
depends = boost-libs>=1.45
- depends = miniupnpc>=1.6
+ depends = openssl
depends = libunwind
depends = readline
depends = zeromq
- depends = unbound>=1.4.16
- depends = openssl
+ depends = pcsclite
source = monero::git+https://github.com/monero-project/monero.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b914e9cdb7d3..5c29b66f898c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,26 +4,15 @@
pkgbase=('monero-git')
pkgname=('monero-git' 'libmonero-wallet-git')
_gitname='monero'
-pkgver=0.12.0.0
+pkgver=0.12.3.0
pkgrel=1
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
url="https://getmonero.org/"
license=('custom:Cryptonote')
-depends=('boost-libs>=1.45' 'miniupnpc>=1.6' 'libunwind'
- 'readline' 'zeromq'
-
- # For OpenSSL v1.1
- 'unbound>=1.4.16' # depends on OpenSSL v1.1
- 'openssl'
-
- # For OpenSSL v1.0
- # use unbound vendored inside upstream source repo
- #'openssl-1.0'
- )
+depends=('boost-libs>=1.45' 'openssl' 'libunwind' 'readline' 'zeromq' 'pcsclite')
makedepends=('git' 'cmake' 'boost' 'gtest' 'qt5-tools')
-
pkgdesc="Peer-to-peer anonymous digital currency (daemon, CLI wallet, and wallet API library)"
_upstream=https://github.com/monero-project/monero.git
source=("$_gitname::git+$_upstream")
@@ -52,10 +41,6 @@ prepare() {
# To apply PRs
#git remote add up $_upstream
#git pull --no-edit up refs/pull/xxxx/head
-
- cd external/miniupnp
- git fetch origin refs/pull/3/head # cmake: do not install into system
- git merge FETCH_HEAD
}
build() {
@@ -95,6 +80,7 @@ check() {
EXCLUDED_UNIT_TESTS+='DNSResolver.IPv4Failure'
EXCLUDED_UNIT_TESTS+=':DNSResolver.DNSSECSuccess'
EXCLUDED_UNIT_TESTS+=':AddressFromURL.Failure'
+ EXCLUDED_UNIT_TESTS+=':ringdb.not_found' # PR #4165
tests/unit_tests/unit_tests --gtest_filter="-$EXCLUDED_UNIT_TESTS" \
--data-dir ../tests/data
@@ -120,9 +106,16 @@ package_monero-git() {
# options=(!strip debug)
install -D -m755 "$srcdir/$_gitname/build/bin/monerod" "$pkgdir/usr/bin/monerod"
+
install -D -m755 "$srcdir/$_gitname/build/bin/monero-wallet-cli" "$pkgdir/usr/bin/monero-wallet-cli"
+ install -D -m755 "$srcdir/$_gitname/build/bin/monero-wallet-rpc" "$pkgdir/usr/bin/monero-wallet-rpc"
+
+ install -D -m755 "$srcdir/$_gitname/build/bin/monero-blockchain-blackball" "$pkgdir/usr/bin/monero-blockchain-blackball"
install -D -m755 "$srcdir/$_gitname/build/bin/monero-blockchain-import" "$pkgdir/usr/bin/monero-blockchain-import"
install -D -m755 "$srcdir/$_gitname/build/bin/monero-blockchain-export" "$pkgdir/usr/bin/monero-blockchain-export"
+ install -D -m755 "$srcdir/$_gitname/build/bin/monero-blockchain-usage" "$pkgdir/usr/bin/monero-blockchain-usage"
+
+ install -D -m755 "$srcdir/$_gitname/build/bin/monero-gen-trusted-multisig" "$pkgdir/usr/bin/monero-gen-trusted-multisig"
install -Dm644 $srcdir/$_gitname/utils/systemd/monerod.service "${pkgdir}/usr/lib/systemd/system/monerod.service"
install -Dm644 "$srcdir/$_gitname/utils/conf/monerod.conf" "$pkgdir/etc/monerod.conf"