summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2020-06-06 02:01:14 -0400
committerredfish2020-06-06 02:01:14 -0400
commit0ff39852e51ee5d3453980d85e87dd5a64edd0fc (patch)
treed637548a957cd103e300e213ee980ef7b4154191
parent4a21c8dfa372a89c86aa85cf38a10389a6b95af2 (diff)
downloadaur-0ff39852e51ee5d3453980d85e87dd5a64edd0fc.tar.gz
0.16.0.0
Need to install headers from epee, because the wallet (monero-wallet-qt-git) needs them now (because some logic for checking for updates was added that uses http_client class).
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD10
-rw-r--r--cmake-headers.patch60
4 files changed, 74 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eaebda55788f..7663839f3e4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = monero-git
pkgdesc = Peer-to-peer anonymous digital currency (daemon, CLI wallet, and wallet API library)
- pkgver = 0.15.0.1
+ pkgver = 0.16.0.0
pkgrel = 1
url = https://getmonero.org/
arch = x86_64
@@ -23,7 +23,9 @@ pkgbase = monero-git
depends = hidapi
depends = protobuf
source = monero::git+https://github.com/monero-project/monero.git
+ source = cmake-headers.patch
sha256sums = SKIP
+ sha256sums = fe716415b67138cf79357c7db8d684d57f9dae4180e755b8143ff5bc7ce47bfc
pkgname = monero-git
install = monero.install
@@ -32,7 +34,7 @@ pkgname = monero-git
backup = etc/monerod.conf
pkgname = libmonero-wallet-git
- provides = libmonero-wallet=0.15.0.1
+ provides = libmonero-wallet=0.16.0.0
conflicts = libmonero-wallet
options = !strip
diff --git a/.gitignore b/.gitignore
index c5a3f78e13ab..4d178eb702aa 100644
--- a/.gitignore
+++ b/.gitignore
@@ -6,4 +6,7 @@ src/
*.tar.xz
+*.pkg.tar.xz
+*.pkg.tar.zst
+
monero/
diff --git a/PKGBUILD b/PKGBUILD
index 1f229ad0590c..29aed6a6aa7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase='monero-git'
pkgname=('monero-git' 'libmonero-wallet-git')
_gitname='monero'
-pkgver=0.15.0.1
+pkgver=0.16.0.0
pkgrel=1
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
url="https://getmonero.org/"
@@ -17,7 +17,8 @@ checkdepends=('python-requests')
pkgdesc="Peer-to-peer anonymous digital currency (daemon, CLI wallet, and wallet API library)"
_upstream=https://github.com/monero-project/monero.git
-source=("$_gitname::git+$_upstream")
+source=("$_gitname::git+$_upstream"
+ 'cmake-headers.patch')
_builddir=build
@@ -35,6 +36,8 @@ pkgver() {
prepare() {
cd "$srcdir/$_gitname"
+ patch -p1 < $srcdir/cmake-headers.patch
+
git submodule init
git submodule update
@@ -142,4 +145,5 @@ package_libmonero-wallet-git() {
cd $_stagedir
find usr/{include,lib} -type f -exec install -D -m 755 {} ${pkgdir}/{} \;
}
-sha256sums=('SKIP')
+sha256sums=('SKIP'
+ 'fe716415b67138cf79357c7db8d684d57f9dae4180e755b8143ff5bc7ce47bfc')
diff --git a/cmake-headers.patch b/cmake-headers.patch
new file mode 100644
index 000000000000..228afe5ecb1d
--- /dev/null
+++ b/cmake-headers.patch
@@ -0,0 +1,60 @@
+--- a/contrib/epee/src/CMakeLists.txt 2020-06-06 01:43:21.457032958 -0400
++++ b/contrib/epee/src/CMakeLists.txt 2020-06-06 01:21:08.961327684 -0400
+@@ -52,6 +52,44 @@
+ install(TARGETS epee_readline
+ ARCHIVE DESTINATION ${lib_folder})
+ endif()
++ install(FILES
++ ../include/net/abstract_http_client.h
++ ../include/net/enums.h
++ ../include/net/http_auth.h
++ ../include/net/http_base.h
++ ../include/net/http_client.h
++ ../include/net/http_client_base.h
++ ../include/net/net_helper.h
++ ../include/net/net_parse_helpers.h
++ ../include/net/net_ssl.h
++ ../include/net/net_utils_base.h
++ DESTINATION include/net)
++ install(FILES
++ ../include/serialization/enableable.h
++ ../include/serialization/keyvalue_serialization.h
++ ../include/serialization/keyvalue_serialization_overloads.h
++ DESTINATION include/serialization)
++ install(FILES
++ ../include/storages/parserse_base_utils.h
++ DESTINATION include/storages)
++ install(FILES
++ ../include/byte_slice.h
++ ../include/fnv1.h
++ ../include/hex.h
++ ../include/int-util.h
++ ../include/memwipe.h
++ ../include/misc_language.h
++ ../include/misc_log_ex.h
++ ../include/mlocker.h
++ ../include/reg_exp_definer.h
++ ../include/span.h
++ ../include/string_coding.h
++ ../include/string_tools.h
++ ../include/syncobj.h
++ ../include/to_nonconst_iterator.h
++ ../include/warnings.h
++ ../include/wipeable_string.h
++ DESTINATION include)
+ endif()
+
+ target_link_libraries(epee
+--- a/external/easylogging++/CMakeLists.txt 2020-06-06 01:42:30.776566825 -0400
++++ b/external/easylogging++/CMakeLists.txt 2020-06-06 01:42:35.803279807 -0400
+@@ -55,6 +55,10 @@
+ install(TARGETS easylogging
+ ARCHIVE DESTINATION ${lib_folder}
+ LIBRARY DESTINATION ${lib_folder})
++ install(FILES
++ easylogging++.h
++ ea_config.h
++ DESTINATION include)
+ endif()
+ set_property(TARGET easylogging APPEND PROPERTY COMPILE_FLAGS "-fPIC")
+