summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2018-08-07 19:23:08 -0400
committerredfish2018-08-07 19:24:46 -0400
commit3d09237a78d9184ee7281960059607b9da48736e (patch)
tree5d815ed702c545b2f33fd2d2b3c43a30a8626934
parent0436507349bb0461e62dde4b3467e90df5060b8d (diff)
downloadaur-3d09237a78d9184ee7281960059607b9da48736e.tar.gz
merge pull requests that fix #4228 and miniupnp installation
Also, switch to sha256sum
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--cmake-libsodium.patch12
3 files changed, 27 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3376f714fea0..32e7a78c37d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Jul 22 02:15:09 UTC 2018
+# Tue Aug 7 23:21:03 UTC 2018
pkgbase = monero-git
pkgdesc = Peer-to-peer anonymous digital currency (daemon, CLI wallet, and wallet API library)
pkgver = 0.12.3.0
@@ -22,7 +22,9 @@ pkgbase = monero-git
depends = zeromq
depends = pcsclite
source = monero::git+https://github.com/monero-project/monero.git
- md5sums = SKIP
+ source = cmake-libsodium.patch
+ sha256sums = SKIP
+ sha256sums = fceaadde45f7fec587a8ce9456e23ca3d1500bc021aae5fdc7a7872362f8891e
pkgname = monero-git
install = monero.install
diff --git a/PKGBUILD b/PKGBUILD
index 5c29b66f898c..58cff0dbdeee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,9 +15,8 @@ makedepends=('git' 'cmake' 'boost' 'gtest' 'qt5-tools')
pkgdesc="Peer-to-peer anonymous digital currency (daemon, CLI wallet, and wallet API library)"
_upstream=https://github.com/monero-project/monero.git
-source=("$_gitname::git+$_upstream")
-
-md5sums=('SKIP')
+source=("$_gitname::git+$_upstream"
+ "cmake-libsodium.patch")
_builddir=build
@@ -41,6 +40,13 @@ prepare() {
# To apply PRs
#git remote add up $_upstream
#git pull --no-edit up refs/pull/xxxx/head
+
+ git pull --no-edit origin refs/pull/4159/head # fixes #4228
+
+ patch -p1 < ../cmake-libsodium.patch
+
+ cd external/miniupnp
+ git pull --no-edit origin refs/pull/3/head # fixes conflict with system miniupnp upon installation
}
build() {
@@ -140,3 +146,5 @@ package_libmonero-wallet-git() {
cd $_stagedir
find usr/{include,lib} -type f -exec install -D -m 755 {} ${pkgdir}/{} \;
}
+sha256sums=('SKIP'
+ 'fceaadde45f7fec587a8ce9456e23ca3d1500bc021aae5fdc7a7872362f8891e')
diff --git a/cmake-libsodium.patch b/cmake-libsodium.patch
new file mode 100644
index 000000000000..49e50769c75e
--- /dev/null
+++ b/cmake-libsodium.patch
@@ -0,0 +1,12 @@
+diff --git a/src/crypto/CMakeLists.txt b/src/crypto/CMakeLists.txt
+index 71dcedca..e2030905 100644
+--- a/src/crypto/CMakeLists.txt
++++ b/src/crypto/CMakeLists.txt
+@@ -79,6 +79,7 @@ target_link_libraries(cncrypto
+ epee
+ ${Boost_SYSTEM_LIBRARY}
+ PRIVATE
++ ${SODIUM_LIBRARY}
+ ${EXTRA_LIBRARIES})
+
+ if (ARM)