summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2017-10-07 13:13:12 -0400
committerredfish2017-10-07 13:13:12 -0400
commit54466069bb15bc3f6511c4765df1557a950a420b (patch)
treeb9fe6267d4b716f67bf3591eac3a163a6b5d2e4e
parent92e35202d7fd8b58f50bbe1c5543b45485470880 (diff)
downloadaur-54466069bb15bc3f6511c4765df1557a950a420b.tar.gz
check: avoid building tests when --nocheck
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b1cb0162e2b6..4bde2f8644ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -44,7 +44,7 @@ build() {
CMAKE_FLAGS+=" -DCMAKE_BUILD_TYPE=$_buildtype "
CMAKE_FLAGS+=" -DCMAKE_INSTALL_PREFIX=/usr "
- CMAKE_FLAGS+=" -DBUILD_TESTS=ON "
+ CMAKE_FLAGS+=" -DBUILD_TESTS=OFF "
CMAKE_FLAGS+=" -DBUILD_GUI_DEPS=ON "
CMAKE_FLAGS+=" -Wno-dev " # silence warnings for devs
@@ -57,6 +57,9 @@ check() {
cd "$srcdir/$_gitname"
cd $_builddir
+ cmake -DBUILD_TESTS=ON ..
+ make
+
# Run unit_tests test separately to exclude DNS tests which often fail with
# DNS nameservers configured on some systems (#2172)
EXCLUDED_UNIT_TESTS+='DNSResolver.IPv4Failure'