summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2016-09-17 01:22:31 -0400
committerredfish2016-09-17 01:32:58 -0400
commit9b6c953b5510185da9592338732e14bb2ea6ea02 (patch)
treee3ade34842150161c78a410606bfdb73863034a0
parent40ed11ee71aa9d55a740e9a2473b975471f0dbdb (diff)
downloadaur-9b6c953b5510185da9592338732e14bb2ea6ea02.tar.gz
check: exclude DNS tests that often fail
-rw-r--r--PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e6f298338c1..8c9e905b5bf4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -58,10 +58,18 @@ check() {
cd "$srcdir/$_gitname"
cd build
+ # Run unit_tests test separately to exclude DNS tests which often fail with
+ # DNS nameservers configured on some systems
+ EXCLUDED_UNIT_TESTS+='DNSResolver.IPv4Failure'
+ EXCLUDED_UNIT_TESTS+=':DNSResolver.DNSSECSuccess'
+ EXCLUDED_UNIT_TESTS+=':AddressFromURL.Failure'
+ tests/unit_tests/unit_tests --gtest_filter="-$EXCLUDED_UNIT_TESTS"
+
# Temporarily disable some a tests:
# * coretests takes too long (~25000s)
# * libwallet_api_tests fail (Issue #895)
- CTEST_ARGS+="-E 'coretests|libwallet_api_tests'"
+ # * unit_tests were run separately above
+ CTEST_ARGS+="-E 'coretests|libwallet_api_tests|unit_tests'"
echo ">>> NOTE: some tests excluded: $CTEST_ARGS"
make ARGS="$CTEST_ARGS" test