summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2017-10-16 01:21:13 -0400
committerredfish2017-10-16 01:24:03 -0400
commite3d92614d7a5153afbcc95d1222ddb0f584faf7a (patch)
tree665616c3619abdf5a6487d50363cc8db76e36508
parent957f96161a51e187a0b59fea6d375eac54eb07d5 (diff)
downloadaur-e3d92614d7a5153afbcc95d1222ddb0f584faf7a.tar.gz
merge pull requests that fix the build
-rw-r--r--PKGBUILD16
1 files changed, 15 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 114a633bb4fd..82bf480beea1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,7 +25,8 @@ makedepends=('git' 'cmake' 'boost' 'gtest')
pkgdesc="Peer-to-peer anonymous digital currency (daemon, CLI wallet, and wallet API library)"
-source=("$_gitname::git+https://github.com/monero-project/monero.git")
+_upstream=https://github.com/monero-project/monero.git
+source=("$_gitname::git+$_upstream")
md5sums=('SKIP')
@@ -41,6 +42,19 @@ pkgver() {
"$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$srcdir/$_gitname"
+
+ git remote add up $_upstream
+
+ if check_option "debug" "y"
+ then
+ git pull --no-edit up refs/pull/2645/head # cmake install path fix
+ fi
+
+ git pull --no-edit up refs/pull/2663/head # fix for openssl v1.1
+}
+
build() {
cd "$srcdir/$_gitname"