summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames P. Harvey2019-10-21 21:04:11 -0400
committerJames P. Harvey2019-10-21 21:04:11 -0400
commit70918cda9a4417bca1b5a6a1319dca464d098e8c (patch)
treef4ba172291382f484270afbae7ecf6e64a95a35c
parent61c919d22c907e80566aa8da0f38b5440e60270a (diff)
downloadaur-70918cda9a4417bca1b5a6a1319dca464d098e8c.tar.gz
4.2.1: Drastically reduce build size and time by preventing building using debug symbols, which will be stripped anyway. Thanks lsr!
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a0964bac8eb..2f65078f71f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -71,6 +71,10 @@ prepare() {
# See: https://jira.mongodb.org/browse/SERVER-38086
sed -i 's/\[Service]/[Service]\nTimeoutStartSec=infinity/' rpm/mongod.service
+ # Prevent building using debug symbols, since binaries will be stripped anyway
+ # Reduces makepkg -- which fully runs check() -- build size from 259GB to 2.3GB, and time by at least 37%
+ # See: https://jira.mongodb.org/browse/SERVER-44038
+ sed -i '/"-ggdb" if not env.TargetOSIs/d' SConstruct
}
build() {