summarylogtreecommitdiffstats
AgeCommit message (Expand)Author
2020-08-21Update to 4.2.8Christoph Bayer
2020-06-03Update to 4.2.7Christoph Bayer
2020-04-27Update to 4.2.6Christoph Bayer
2019-12-28Upstream released 4.2.2.James P. Harvey
2019-10-214.2.1: Drastically reduce build size and time by preventing building using de...James P. Harvey
2019-10-214.2.1: Includes systemLibraries.patch, so remove it.James P. Harvey
2019-10-21Upstream released 4.2.1.James P. Harvey
2019-10-12Upstream has compatibility issue with newly released yaml-cpp 0.6.3. Don't u...James P. Harvey
2019-08-27Upstream has compatability issue with pcre 8.43. Don't use system pcre until...James P. Harvey
2019-08-21Disable tests under devtools. 4.2.0 has so many tests fail in devtools (due ...James P. Harvey
2019-08-21No longer use system wiredtiger. Upstream broke using as a separate package ...James P. Harvey
2019-08-20Add upstream patch to fix 4.2.0 build failure using system libraries.James P. Harvey
2019-08-204.2.0 finally supports building with python3. Re-do make and check depends. ...James P. Harvey
2019-08-20Upstream released 4.2.0.James P. Harvey
2019-08-20Require python2-scons minimum version 3.1.1. No need to bump pkgrel for anyo...James P. Harvey
2019-08-14Run 'scons2' instead of 'scons'. Dependency 'aur/python2-scons' renamed its ...James P. Harvey
2019-08-09Upstream released 4.0.12.James P. Harvey
2019-08-09Require aur/python2-scons. extra/scons changed from using python2 to python3...James P. Harvey
2019-07-25Upstream released 4.0.11.James P. Harvey
2019-05-29Upstream released 4.0.10.James P. Harvey
2019-04-13Upstream released 4.0.9.James P. Harvey
2019-03-30Upstream released 4.0.8. Upstream didn't bump required version of wiredtiger.James P. Harvey
2019-03-264.0.7 requires new version of wiredtiger. See https://github.com/mongodb/mon...James P. Harvey
2019-03-26Upgrading to version 4.0.7Fredy GarcĂ­a
2019-02-24Make systemd wait as long as it takes for MongoDB to start.James P. Harvey
2019-02-21Tag 4.0.6-2, and update comments.James P. Harvey
2019-02-21Require unittests pass. If running through devtools, disable unittests using...James P. Harvey
2019-02-21Don't try to build tools, because they aren't here anymore.James P. Harvey
2019-02-21Install manpages.James P. Harvey
2019-02-21Use upstream service file, but keep it as mongodb and modify it to: keep hist...James P. Harvey
2019-02-21Use upstream conf file, but keep it as /etc/mongodb.conf and modify it to kee...James P. Harvey
2019-02-21Make wiredtiger dependency require minimum version of that required by 4.0.6....James P. Harvey
2019-02-21Remove setting LANG. This was added in 3.2.0-1 because a test was giving a l...James P. Harvey
2019-02-21Re-enable test 'oplog_buffer_collection_test'. This was disabled in 3.4.2-1 ...James P. Harvey
2019-02-21Strip binaries, per default Arch policy. This was disabled in 3.2.0-1 withou...James P. Harvey
2019-02-21Remove disabled '--use-system-v8' option with compilation error comment. Thi...James P. Harvey
2019-02-21Re-enable tls13 support. This was disabled in 4.0.2-1 due to a compilation e...James P. Harvey
2019-02-21Re-enable '--use-system-tcmalloc'. This was disabled in 3.0.0-1 due to a com...James P. Harvey
2019-02-21Remove install_compass, because it won't run on arch, and AUR package mongodb...James P. Harvey
2019-02-21Change license from AGPL3 to SSPL, which applies to releases after October 16...James P. Harvey
2019-02-12Upgrading to version 4.0.6frealgagu
2019-01-19moved from [community]Felix Yan