summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustKidding2022-02-05 20:58:09 -0500
committerJustKidding2022-02-05 20:58:09 -0500
commita21bbcdc315c95ca742c6f6efb5595a395b340d6 (patch)
tree1ca3698d1833d0582b89b0772aaab201b113dd62
parentd5fcf309115f316a76a6380f0c79bcef761b8bdb (diff)
downloadaur-a21bbcdc315c95ca742c6f6efb5595a395b340d6.tar.gz
add patches
-rw-r--r--PKGBUILD7
-rw-r--r--mongodb-4.4.1-boost.patch23
-rw-r--r--mongodb-5.0.2-no-compass.patch12
3 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0a4efab0d680..0576b30aa13c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,10 +27,14 @@ source=(
"${pkgname}.sysusers"
"${pkgname}.tmpfiles"
"mongodb-5.0.2-skip-no-exceptions.patch"
+ "mongodb-4.4.1-boost.patch"
+ "mongodb-5.0.2-no-compass.patch"
)
sha256sums=('9d514eef9093d383120aebe4469c8118a39f390afcd8cd9af2399076b27abb52'
'3757d548cfb0e697f59b9104f39a344bb3d15f802608085f838cb2495c065795'
'b7d18726225cd447e353007f896ff7e4cbedb2f641077bce70ab9d292e8f8d39'
+ 'SKIP'
+ 'SKIP'
'SKIP')
_scons_args=(
@@ -80,7 +84,10 @@ prepare() {
# See: https://jira.mongodb.org/browse/SERVER-44038
sed -i '/"-ggdb" if not env.TargetOSIs/d' SConstruct
+ # gentoo patches
patch -Np1 -i ../mongodb-5.0.2-skip-no-exceptions.patch
+ patch -Np1 -i ../mongodb-5.0.2-no-compass.patch
+ patch -Np1 -i ../mongodb-4.4.1-boost.patch
}
build() {
diff --git a/mongodb-4.4.1-boost.patch b/mongodb-4.4.1-boost.patch
new file mode 100644
index 000000000000..009ca6826a4f
--- /dev/null
+++ b/mongodb-4.4.1-boost.patch
@@ -0,0 +1,23 @@
+diff --git a/SConstruct b/SConstruct
+index 89c044ab..0484e475 100644
+--- a/SConstruct
++++ b/SConstruct
+@@ -3511,17 +3511,11 @@ def doConfigure(myenv):
+ "BOOST_LOG_NO_SHORTHAND_NAMES",
+ "BOOST_LOG_USE_NATIVE_SYSLOG",
+ "BOOST_LOG_WITHOUT_THREAD_ATTR",
++ "BOOST_LOG_DYN_LINK",
+ "ABSL_FORCE_ALIGNED_ACCESS",
+ ]
+ )
+
+- if link_model.startswith("dynamic") and not link_model == 'dynamic-sdk':
+- conf.env.AppendUnique(
+- CPPDEFINES=[
+- "BOOST_LOG_DYN_LINK",
+- ]
+- )
+-
+ if use_system_version_of_library("boost"):
+ if not conf.CheckCXXHeader( "boost/filesystem/operations.hpp" ):
+ myenv.ConfError("can't find boost headers")
diff --git a/mongodb-5.0.2-no-compass.patch b/mongodb-5.0.2-no-compass.patch
new file mode 100644
index 000000000000..777251577298
--- /dev/null
+++ b/mongodb-5.0.2-no-compass.patch
@@ -0,0 +1,12 @@
+diff --git a/src/mongo/installer/SConscript b/src/mongo/installer/SConscript
+index 5bd89fe9..489e70ac 100644
+--- a/src/mongo/installer/SConscript
++++ b/src/mongo/installer/SConscript
+@@ -7,7 +7,6 @@ env = env.Clone()
+
+ env.SConscript(
+ dirs=[
+- 'compass',
+ 'msi',
+ ],
+ exports=[