summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames P. Harvey2019-08-14 22:11:46 -0400
committerJames P. Harvey2019-08-14 22:11:46 -0400
commite47bd9c833ad4d3c90d20fc4ef2f349f9e4d0c56 (patch)
treef49f607726c69fd47ccc5d7ef310ead9a05fc74c
parenta60651031e1e8279f1698e1dcccbf17e987976af (diff)
downloadaur-e47bd9c833ad4d3c90d20fc4ef2f349f9e4d0c56.tar.gz
Run 'scons2' instead of 'scons'. Dependency 'aur/python2-scons' renamed its binaries to no longer conflict with 'extra/scons'.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4226b0ea2056..a7a7dc531499 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mongodb
pkgdesc = A high-performance, open source, schema-free document-oriented database
pkgver = 4.0.12
- pkgrel = 1
+ pkgrel = 2
url = https://www.mongodb.com/
arch = x86_64
license = custom:SSPL
diff --git a/PKGBUILD b/PKGBUILD
index f88d83508655..3731d155d1cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
pkgname=mongodb
# #.<odd number>.# releases are unstable development/testing
pkgver=4.0.12
-pkgrel=1
+pkgrel=2
pkgdesc="A high-performance, open source, schema-free document-oriented database"
arch=("x86_64")
url="https://www.${pkgname}.com/"
@@ -76,7 +76,7 @@ build() {
cd "${srcdir}/${pkgname}-src-r${pkgver}"
export SCONSFLAGS="$MAKEFLAGS"
- scons core "${_scons_args[@]}"
+ scons2 core "${_scons_args[@]}"
}
check() {
@@ -84,7 +84,7 @@ check() {
export SCONSFLAGS="$MAKEFLAGS"
- scons unittests "${_scons_args[@]}"
+ scons2 unittests "${_scons_args[@]}"
# These use mlock(), which will fail under systemd-nspawn (using devtools)
# See https://jira.mongodb.org/browse/SERVER-32773
@@ -102,17 +102,17 @@ check() {
python2 "${srcdir}/${pkgname}-src-r${pkgver}/buildscripts/resmoke.py" --suites=unittests
- scons dbtest "${_scons_args[@]}"
+ scons2 dbtest "${_scons_args[@]}"
python2 "${srcdir}/${pkgname}-src-r${pkgver}/buildscripts/resmoke.py" --suites=dbtest
- scons integration_tests "${_scons_args[@]}"
+ scons2 integration_tests "${_scons_args[@]}"
python2 "${srcdir}/${pkgname}-src-r${pkgver}/buildscripts/resmoke.py" --suites=integration_tests_replset,integration_tests_standalone --dbpathPrefix="${srcdir}"
}
package() {
cd "${srcdir}/${pkgname}-src-r${pkgver}"
- scons install --prefix="${pkgdir}/usr" "${_scons_args[@]}"
+ scons2 install --prefix="${pkgdir}/usr" "${_scons_args[@]}"
# Keep historical Arch conf file name
install -Dm644 "rpm/mongod.conf" "${pkgdir}/etc/${pkgname}.conf"