summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAli Molaei2021-11-22 12:46:10 +0330
committerAli Molaei2021-11-22 12:46:10 +0330
commitcf3e6bcb4e3cefaa460d89a22add99ef1c21eb8b (patch)
tree0ec6ec054c24d4c0ac30a98dcb225beede2df724
parent7585fea66a10d675a80b66a945dcccf6606af7f4 (diff)
downloadaur-cf3e6bcb4e3cefaa460d89a22add99ef1c21eb8b.tar.gz
Add mongosh as an optional dep
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2962b1488f36..53428c33e167 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,6 +9,7 @@ pkgbase = mongodb-bin
license = Apache
depends = curl
optdepends = mongodb-tools: The MongoDB tools provide import, export, and diagnostic capabilities.
+ optdepends = mongosh: An interactive shell to connect with MongoDB with syntax highlighting, autocomplete, contextual help and error messages.
provides = mongodb=5.0.4
conflicts = mongodb
conflicts = mongodb-shell-bin
diff --git a/PKGBUILD b/PKGBUILD
index 240bef1195e8..685e5f1bfd22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,8 @@ arch=("x86_64" "aarch64")
url="https://www.mongodb.com/"
license=("custom:SSPLv1" "Apache")
depends=("curl")
-optdepends=("mongodb-tools: The MongoDB tools provide import, export, and diagnostic capabilities.")
+optdepends=("mongodb-tools: The MongoDB tools provide import, export, and diagnostic capabilities."
+ "mongosh: An interactive shell to connect with MongoDB with syntax highlighting, autocomplete, contextual help and error messages.")
provides=("mongodb=$pkgver")
conflicts=("mongodb" "mongodb-shell-bin")
backup=("etc/mongodb.conf")