summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaha Jahangir2019-04-27 12:41:49 +0430
committerTaha Jahangir2019-04-27 12:44:34 +0430
commitf449a4ca34bb2a43dd89751cb0e9f83f6cd49f07 (patch)
tree7d1faeb519c78a179d47cd311406e6780ceef8d0
parentb8855c1d3ba152caf8774f172cf71d2f81ddc40b (diff)
downloadaur-mongodb-bin-3.6.tar.gz
Change to Mongodb 3.6.12
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD23
2 files changed, 23 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7670a78b8386..563ecd1493e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,31 @@
-pkgbase = mongodb-bin
+pkgbase = mongodb-bin-3.6
pkgdesc = A high-performance, open source, schema-free document-oriented database
- pkgver = 4.0.9
+ pkgver = 3.6.12
pkgrel = 1
url = https://www.mongodb.com/
arch = x86_64
license = SSPLv1
optdepends = mongodb-tools: The MongoDB tools provide import, export, and diagnostic capabilities.
- provides = mongodb=4.0.9
+ provides = mongodb=3.6.12
conflicts = mongodb
+ conflicts = mongodb-bin
backup = etc/mongodb.conf
- source = https://repo.mongodb.org/apt/ubuntu/dists/bionic/mongodb-org/4.0/multiverse/binary-amd64/mongodb-org-shell_4.0.9_amd64.deb
- source = https://repo.mongodb.org/apt/ubuntu/dists/bionic/mongodb-org/4.0/multiverse/binary-amd64/mongodb-org-server_4.0.9_amd64.deb
- source = https://repo.mongodb.org/apt/ubuntu/dists/bionic/mongodb-org/4.0/multiverse/binary-amd64/mongodb-org-mongos_4.0.9_amd64.deb
+ source = https://repo.mongodb.org/apt/debian/dists/jessie/mongodb-org/3.6/main/binary-amd64/mongodb-org-shell_3.6.12_amd64.deb
+ source = https://repo.mongodb.org/apt/debian/dists/jessie/mongodb-org/3.6/main/binary-amd64/mongodb-org-server_3.6.12_amd64.deb
+ source = https://repo.mongodb.org/apt/debian/dists/jessie/mongodb-org/3.6/main/binary-amd64/mongodb-org-mongos_3.6.12_amd64.deb
source = mongodb.service
source = mongodb.conf
source = mongodb.sysusers
source = mongodb.tmpfiles
source = LICENSE
- sha256sums = 2641dfb47e5c79bb03c2adc7df0993901c6f8a0f9722a43076f0c222a0324673
- sha256sums = 7f5834943b9869ac395e5713a654680876f6eb4fa8abc813aa0e9f6f69503612
- sha256sums = 25765030ac6441185d3a20e6e95bc9401158b723586e759cfd635127ed7f2b79
+ sha256sums = 4e6e575d850d0f0f238c8fb159c552ce107f895f4049c4fca05efd366545c490
+ sha256sums = 85da8f5a2a30a336212e3574f1fedd4fe8757b17e710fd53561f8ab1204ad3e3
+ sha256sums = ce66b8e216ced21e7e5d2387209c6b14805cc755c87a9733e2a760ee8cd4c52b
sha256sums = 19f55ab28652b3817e98fc3f15cc2f6f3255a5e1dfd7b0d5a27c9ba22fd2703e
sha256sums = 8010ce728d657524cd76b5afda7ffbc1cc389642336b12b89cec5df2b09fc0e4
sha256sums = 47b884569102f7c79017ee78ef2e98204a25aa834c0ee7d5d62c270ab05d4e2b
sha256sums = 51ee1e1f71598aad919db79a195778e6cb6cfce48267565e88a401ebc64497ac
sha256sums = 09d99ca61eb07873d5334077acba22c33e7f7d0a9fa08c92734e0ac8430d6e27
-pkgname = mongodb-bin
+pkgname = mongodb-bin-3.6
diff --git a/PKGBUILD b/PKGBUILD
index 69f5a0381bce..9ff0c35c2431 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,30 @@
-#Maintainer: Ali Molaei <ali dot molaei at protonmail dot com>
+#Maintainer: Mohammad Taha Jahangir (taha_jahangir)
+#Maintainer of mongodb-bin: Ali Molaei <ali dot molaei at protonmail dot com>
-pkgname="mongodb-bin"
-pkgver="4.0.9"
-basever="4.0"
+pkgname="mongodb-bin-3.6"
+pkgver="3.6.12"
+basever="3.6"
pkgrel="1"
pkgdesc="A high-performance, open source, schema-free document-oriented database"
arch=("x86_64")
url="https://www.mongodb.com/"
license=("SSPLv1")
provides=("mongodb=$pkgver")
-conflicts=("mongodb")
+conflicts=("mongodb" "mongodb-bin")
optdepends=("mongodb-tools: The MongoDB tools provide import, export, and diagnostic capabilities.")
source=(
- "https://repo.mongodb.org/apt/ubuntu/dists/bionic/mongodb-org/${basever}/multiverse/binary-amd64/mongodb-org-shell_${pkgver}_amd64.deb"
- "https://repo.mongodb.org/apt/ubuntu/dists/bionic/mongodb-org/${basever}/multiverse/binary-amd64/mongodb-org-server_${pkgver}_amd64.deb"
- "https://repo.mongodb.org/apt/ubuntu/dists/bionic/mongodb-org/${basever}/multiverse/binary-amd64/mongodb-org-mongos_${pkgver}_amd64.deb"
+ "https://repo.mongodb.org/apt/debian/dists/jessie/mongodb-org/${basever}/main/binary-amd64/mongodb-org-shell_${pkgver}_amd64.deb"
+ "https://repo.mongodb.org/apt/debian/dists/jessie/mongodb-org/${basever}/main/binary-amd64/mongodb-org-server_${pkgver}_amd64.deb"
+ "https://repo.mongodb.org/apt/debian/dists/jessie/mongodb-org/${basever}/main/binary-amd64/mongodb-org-mongos_${pkgver}_amd64.deb"
"mongodb.service"
"mongodb.conf"
"mongodb.sysusers"
"mongodb.tmpfiles"
"LICENSE")
-sha256sums=("2641dfb47e5c79bb03c2adc7df0993901c6f8a0f9722a43076f0c222a0324673"
- "7f5834943b9869ac395e5713a654680876f6eb4fa8abc813aa0e9f6f69503612"
- "25765030ac6441185d3a20e6e95bc9401158b723586e759cfd635127ed7f2b79"
+sha256sums=("4e6e575d850d0f0f238c8fb159c552ce107f895f4049c4fca05efd366545c490"
+ "85da8f5a2a30a336212e3574f1fedd4fe8757b17e710fd53561f8ab1204ad3e3"
+ "ce66b8e216ced21e7e5d2387209c6b14805cc755c87a9733e2a760ee8cd4c52b"
"19f55ab28652b3817e98fc3f15cc2f6f3255a5e1dfd7b0d5a27c9ba22fd2703e"
"8010ce728d657524cd76b5afda7ffbc1cc389642336b12b89cec5df2b09fc0e4"
"47b884569102f7c79017ee78ef2e98204a25aa834c0ee7d5d62c270ab05d4e2b"