summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-05-09 13:57:10 +0200
committerDaniel Peukert2020-05-09 13:57:10 +0200
commit0bb7bfb643df360a08f8a6b6165deaf2aedbad7a (patch)
tree0f49ec8d4fb56d1e83d0786550cc0a15d8fb1588
parent033928d21e965a8f604bf70584517c3126f24c83 (diff)
downloadaur-0bb7bfb643df360a08f8a6b6165deaf2aedbad7a.tar.gz
Patched mongodb-compass to not use external ffmpeg
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--hadron-build.diff (renamed from hadron-build-packaging.diff)23
3 files changed, 31 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 369e7c5e4d1f..315831fdd149 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mongodb-compass-git
pkgdesc = The official GUI for MongoDB - git version
pkgver = 1.22.0.r3278.1f7cf26b
- pkgrel = 3
+ pkgrel = 4
url = https://www.mongodb.com/products/compass
arch = x86_64
arch = i686
@@ -19,8 +19,8 @@ pkgbase = mongodb-compass-git
provides = mongodb-compass
conflicts = mongodb-compass
source = mongodb-compass-git::git+https://github.com/mongodb-js/compass
- source = hadron-build-packaging.diff
+ source = hadron-build.diff
sha256sums = SKIP
- sha256sums = 87ec3245af05788c1c0d7070fcd4e425a0a22dbf7a4ae194a5dce8ade88d519a
+ sha256sums = d6771bf2fc0efb0ae4c3e20ce51e0a8d65c3e702afe8a5333e9ada109ee5e190
pkgname = mongodb-compass-git
diff --git a/PKGBUILD b/PKGBUILD
index 97a86494a9c5..d6f17f63d691 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _edition=''
_pkgname="mongodb-$_target"
pkgname="$_pkgname-git"
pkgver='1.22.0.r3278.1f7cf26b'
-pkgrel='3'
+pkgrel='4'
pkgdesc='The official GUI for MongoDB - git version'
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
url='https://www.mongodb.com/products/compass'
@@ -15,10 +15,10 @@ provides=("$_pkgname")
conflicts=("$_pkgname")
source=(
"$pkgname::git+https://github.com/mongodb-js/compass"
- 'hadron-build-packaging.diff'
+ 'hadron-build.diff'
)
sha256sums=('SKIP'
- '87ec3245af05788c1c0d7070fcd4e425a0a22dbf7a4ae194a5dce8ade88d519a')
+ 'd6771bf2fc0efb0ae4c3e20ce51e0a8d65c3e702afe8a5333e9ada109ee5e190')
_sourcedirectory="$pkgname"
@@ -40,8 +40,8 @@ prepare() {
# Prepare dependencies
HOME="$srcdir/$pkgname-home" npm install
- # Disable hadron-build packaging
- patch -d 'node_modules/hadron-build/' --forward -p1 < '../hadron-build-packaging.diff'
+ # Apply hadron-build fixes
+ patch -d 'node_modules/hadron-build/' --forward -p1 < '../hadron-build.diff'
}
pkgver() {
diff --git a/hadron-build-packaging.diff b/hadron-build.diff
index 71ef5f6fc660..6d59b7c338ee 100644
--- a/hadron-build-packaging.diff
+++ b/hadron-build.diff
@@ -23,3 +23,26 @@ index ea6b71e..6f77a55 100644
- });
});
};
+diff --git a/lib/target.js b/lib/target.js
+index b796546..822cd1e 100644
+--- a/lib/target.js
++++ b/lib/target.js
+@@ -6,8 +6,6 @@ const semver = require('semver');
+ const path = require('path');
+ const normalizePkg = require('normalize-package-data');
+ const parseGitHubRepoURL = require('parse-github-repo-url');
+-const ffmpegAfterExtract = require('electron-packager-plugin-non-proprietary-codecs-ffmpeg')
+- .default;
+ const debug = require('debug')('hadron-build:target');
+
+ const notary = require('mongodb-notary-service-client');
+@@ -176,8 +174,7 @@ class Target {
+ platform: this.platform,
+ arch: this.arch,
+ electronVersion: this.electronVersion,
+- sign: null,
+- afterExtract: [ffmpegAfterExtract]
++ sign: null
+ };
+
+ if (this.platform === 'win32') {