summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-02-15 12:07:02 +0100
committerDaniel Peukert2024-02-15 12:07:02 +0100
commitdcc704bbc3d9c33adb915e1a01b1f30c2bdbb5fe (patch)
treed98f68d53c59adea9d5c2393c8bbd7b6972e0ff1
parentc24e86096eb9ab165454638ec3eebe35b216cd7c (diff)
downloadaur-dcc704bbc3d9c33adb915e1a01b1f30c2bdbb5fe.tar.gz
Remove unnecessary patch from mongodb-compass-git
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--hadron-build-os-dns-native.diff15
3 files changed, 2 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e99747241c4..c2176f2eedea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mongodb-compass-git
pkgdesc = The official GUI for MongoDB - git version
- pkgver = r16716.gfd2aab99c
+ pkgver = r16779.g20a6ff866
pkgrel = 1
epoch = 1
url = https://www.mongodb.com/products/compass
@@ -22,11 +22,9 @@ pkgbase = mongodb-compass-git
conflicts = mongodb-compass
source = mongodb-compass-git::git+https://github.com/mongodb-js/compass
source = hadron-build-ffmpeg.diff
- source = hadron-build-os-dns-native.diff
source = fix-argv.diff
sha512sums = SKIP
sha512sums = 6338626b9c957c79cd761f19a3d17d856ff88ce96d38c5507269b8dbaf3f20bef00012d035e5e1bde6493db495e2cfce172bcd021a5a8ae1c37dcb5f7a46a875
- sha512sums = 084dfe4feae0ac1997a141ac92294b4d132301bd493162abfe0a5acdff2f997928e5b24f21c27bcbce6c74b6b1d1014738d43a387074d7a3b5296279bbb15f6c
sha512sums = 375142120fd97a3fd9e24d19c864ee3b24e50a5e6b0b224b7ce74742dc5bde185056a9b6f1add63d5ce66e3f0a9309e03873096540e5697547d60a2bc9e769ae
pkgname = mongodb-compass-git
diff --git a/PKGBUILD b/PKGBUILD
index 15b5ea96615d..630fc8ea1904 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ _target='compass'
_edition=''
_pkgname="mongodb-$_target"
pkgname="$_pkgname-git"
-pkgver='r16716.gfd2aab99c'
+pkgver='r16779.g20a6ff866'
pkgrel='1'
epoch='1'
pkgdesc='The official GUI for MongoDB - git version'
@@ -21,12 +21,10 @@ conflicts=("$_pkgname")
source=(
"$pkgname::git+https://github.com/mongodb-js/compass"
'hadron-build-ffmpeg.diff'
- 'hadron-build-os-dns-native.diff'
'fix-argv.diff'
)
sha512sums=('SKIP'
'6338626b9c957c79cd761f19a3d17d856ff88ce96d38c5507269b8dbaf3f20bef00012d035e5e1bde6493db495e2cfce172bcd021a5a8ae1c37dcb5f7a46a875'
- '084dfe4feae0ac1997a141ac92294b4d132301bd493162abfe0a5acdff2f997928e5b24f21c27bcbce6c74b6b1d1014738d43a387074d7a3b5296279bbb15f6c'
'375142120fd97a3fd9e24d19c864ee3b24e50a5e6b0b224b7ce74742dc5bde185056a9b6f1add63d5ce66e3f0a9309e03873096540e5697547d60a2bc9e769ae')
_sourcedirectory="$pkgname"
@@ -43,10 +41,6 @@ prepare() {
# Force the newest version of electron-to-chromium
sed -E -i 's|(.*)("electron": ")|\1"electron-to-chromium": "'"$(npm view 'electron-to-chromium@latest' version)"'",\n\1\2|' 'packages/compass/package.json'
- # Use a new version of os-dns-native
- sed -E -i "s|(.*)\"os-dns-native\": \".*\",|\1\"os-dns-native\": \"1\.2\.1\",|" 'packages/compass/package.json'
- patch --forward -p1 < "$srcdir/hadron-build-os-dns-native.diff"
-
# Don't use the bundled ffmpeg
patch --forward -p1 < "$srcdir/hadron-build-ffmpeg.diff"
diff --git a/hadron-build-os-dns-native.diff b/hadron-build-os-dns-native.diff
deleted file mode 100644
index 56be7ff2e5d8..000000000000
--- a/hadron-build-os-dns-native.diff
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/packages/hadron-build/commands/release.js b/packages/hadron-build/commands/release.js
-index 3fee4a5b8..0bb22f348 100644
---- a/packages/hadron-build/commands/release.js
-+++ b/packages/hadron-build/commands/release.js
-@@ -272,6 +272,10 @@ const transformPackageJson = async(CONFIG, done) => {
- 'optionalDependencies'
- ]) {
- for (const depName of Object.keys(contents[depType] || {})) {
-+ if (depName === 'os-dns-native') {
-+ contents[depType][depName] = '1.2.1';
-+ continue;
-+ }
- const depEdge = packageNode.edgesOut.get(depName);
- if (!depEdge.to && !depEdge.optional) {
- throw new Error(