summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames P. Harvey2019-02-15 04:46:12 -0500
committerjamespharvey202019-02-20 18:23:35 -0500
commit88eba5d4ba420ddfd977c81093e158eb68294782 (patch)
treee481236f8dfb33f75a307f707a8eae7f2f2187fb
parentf01f084414d80b4a2bde9b8e5ad9bd07a3948f78 (diff)
downloadaur-88eba5d4ba420ddfd977c81093e158eb68294782.tar.gz
Upstream released 4.0.6. Remove 'disable-sslv3.patch' that was last used in 3.2.5-1. Remove already satisfied dependencies libsasl and openssl.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
-rw-r--r--disable-sslv3.patch13
3 files changed, 24 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 615b5d961efd..f6cec8242725 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,16 @@
# Generated by mksrcinfo v8
-# Thu Feb 14 16:04:55 UTC 2019
+# Fri Feb 15 09:44:25 UTC 2019
pkgbase = mongodb-tools
pkgdesc = The MongoDB tools provide import, export, and diagnostic capabilities.
- pkgver = 4.0.5
- pkgrel = 2
+ pkgver = 4.0.6
+ pkgrel = 1
url = https://github.com/mongodb/mongo-tools
arch = x86_64
license = Apache
makedepends = go-pie
- depends = libsasl
depends = libpcap
- depends = openssl
- source = mongodb-tools-4.0.5.tar.gz::https://github.com/mongodb/mongo-tools/archive/r4.0.5.tar.gz
- source = disable-sslv3.patch
- sha512sums = 5a2ca0cb761895a6c3187bdf4ac0c11222ac681313c2c22801571a1147e07b7b6149150b07e58cd4487413017da56424ec494eaaf9aec9193498ee3cde73c5da
- sha512sums = 674af43ebf9e73f1eae4f81c160cec4c4ea657b7e38f97929a0845d8981f9af904eca79e2144e6150774799a58074cee5b67e4385d082630c471e438981d9ea5
+ source = mongodb-tools-4.0.6.tar.gz::https://github.com/mongodb/mongo-tools/archive/r4.0.6.tar.gz
+ sha512sums = d6185d7442a593d29db78889c55aba53e070bedd522d78d8c0bf52bb27f26c5fee6d010457f65774ea36a2e6d5280f38c95433ff76ed53ed9d74b1c811198cb7
pkgname = mongodb-tools
diff --git a/PKGBUILD b/PKGBUILD
index 48b0a2114499..47b2bc44074e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,25 @@
-# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Maintainer: James P. Harvey <jamespharvey20 at gmail dot com>
+# Maintainer: Fredy GarcĂ­a <frealgagu at gmail dot com>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
pkgname=mongodb-tools
-pkgver=4.0.5
-pkgrel=2
+pkgver=4.0.6
+pkgrel=1
pkgdesc="The MongoDB tools provide import, export, and diagnostic capabilities."
arch=('x86_64')
url="https://github.com/mongodb/mongo-tools"
license=('Apache')
-depends=('libsasl' 'libpcap' 'openssl')
+depends=('libpcap')
makedepends=('go-pie')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/mongodb/mongo-tools/archive/r$pkgver.tar.gz"
- "disable-sslv3.patch")
-sha512sums=('5a2ca0cb761895a6c3187bdf4ac0c11222ac681313c2c22801571a1147e07b7b6149150b07e58cd4487413017da56424ec494eaaf9aec9193498ee3cde73c5da'
- '674af43ebf9e73f1eae4f81c160cec4c4ea657b7e38f97929a0845d8981f9af904eca79e2144e6150774799a58074cee5b67e4385d082630c471e438981d9ea5')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/mongodb/mongo-tools/archive/r${pkgver}.tar.gz")
+sha512sums=('d6185d7442a593d29db78889c55aba53e070bedd522d78d8c0bf52bb27f26c5fee6d010457f65774ea36a2e6d5280f38c95433ff76ed53ed9d74b1c811198cb7')
+
+_tools=('bsondump' 'mongostat' 'mongofiles' 'mongoexport' 'mongoimport' 'mongorestore' 'mongodump' 'mongotop' 'mongoreplay')
prepare() {
+ cd "${srcdir}"
install -d build/src/github.com/mongodb
- mv mongo-tools-r$pkgver build/src/github.com/mongodb/mongo-tools
+ mv "mongo-tools-r${pkgver}" build/src/github.com/mongodb/mongo-tools
cd build/src/github.com/mongodb/mongo-tools
GOROOT=/usr ./set_goenv.sh
export GOPATH="$GOPATH:$srcdir/build"
@@ -24,15 +27,16 @@ prepare() {
}
build() {
- cd build/src/github.com/mongodb/mongo-tools
- for i in bsondump mongostat mongofiles mongoexport mongoimport mongorestore mongodump mongotop mongoreplay; do
- go build -o bin/$i -tags "ssl sasl" $i/main/$i.go
+ cd "${srcdir}/build/src/github.com/mongodb/mongo-tools"
+ for tool in "${_tools[@]}"; do
+ echo "Building ${tool}..."
+ go build -o "bin/${tool}" -tags "ssl sasl" "${tool}/main/${tool}.go"
done
}
package() {
- cd build/src/github.com/mongodb/mongo-tools
- for i in bsondump mongostat mongofiles mongoexport mongoimport mongorestore mongodump mongotop mongoreplay; do
- install -Dm755 bin/$i "$pkgdir/usr/bin/$i"
+ cd "${srcdir}/build/src/github.com/mongodb/mongo-tools"
+ for tool in "${_tools[@]}"; do
+ install -Dm755 "bin/${tool}" "${pkgdir}/usr/bin/${tool}"
done
}
diff --git a/disable-sslv3.patch b/disable-sslv3.patch
deleted file mode 100644
index b1e16395ec63..000000000000
--- a/disable-sslv3.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git i/vendor/src/github.com/spacemonkeygo/openssl/ctx.go w/vendor/src/github.com/spacemonkeygo/openssl/ctx.go
-index 22d6dd1..25b0eec 100644
---- i/vendor/src/github.com/spacemonkeygo/openssl/ctx.go
-+++ w/vendor/src/github.com/spacemonkeygo/openssl/ctx.go
-@@ -141,7 +141,7 @@ func NewCtxWithVersion(version SSLVersion) (*Ctx, error) {
- var method *C.SSL_METHOD
- switch version {
- case SSLv3:
-- method = C.SSLv3_method()
-+ method = C.SSLv23_method()
- case TLSv1:
- method = C.TLSv1_method()
- case TLSv1_1: