summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAli Molaei2024-04-29 12:32:23 +0330
committerAli Molaei2024-04-29 12:32:23 +0330
commitaaac11a537f0cfc7d29c10676515d839fcd60828 (patch)
tree0cd6cf14719eccd59a0acec8223349548f6509f4
parent38247b8b25366c204e530d2ca4bc4b60c9d33dda (diff)
downloadaur-mongosh-bin.tar.gz
Update to 2.2.5
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD22
2 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b07f7b97ae04..a7ea4f5a1de4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mongosh-bin
pkgdesc = An interactive shell to connect with MongoDB with syntax highlighting, autocomplete, contextual help and error messages.
- pkgver = 2.2.4
+ pkgver = 2.2.5
pkgrel = 1
url = https://github.com/mongodb-js/mongosh.git
arch = x86_64
@@ -9,9 +9,9 @@ pkgbase = mongosh-bin
depends = krb5
provides = mongosh
conflicts = mongosh
- source_x86_64 = https://downloads.mongodb.com/compass/mongosh-2.2.4-linux-x64.tgz
- sha256sums_x86_64 = cccab6a6194cc8b8a27c754f1a3c02d8379726c47ce5a923a2027391c94fe784
- source_aarch64 = https://downloads.mongodb.com/compass/mongosh-2.2.4-linux-arm64.tgz
- sha256sums_aarch64 = 2e40cd44b238feef335c6f0b969966dfe1e77fbdffcc8244c5e8ed78788a6de2
+ source_x86_64 = https://downloads.mongodb.com/compass/mongosh-2.2.5-linux-x64.tgz
+ sha256sums_x86_64 = 5f0facb8ec2e76e722cff44d97ee6f5823d572f754e212709c3015ae0f9221ed
+ source_aarch64 = https://downloads.mongodb.com/compass/mongosh-2.2.5-linux-arm64.tgz
+ sha256sums_aarch64 = 336219b676a54391e21c28c1228c4abe9622c2b7ef762471ed4f58c29dd35634
pkgname = mongosh-bin
diff --git a/PKGBUILD b/PKGBUILD
index cc7e32180ee1..a964dc29a3ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=mongosh-bin
_pkgname=mongosh
-pkgver=2.2.4
+pkgver=2.2.5
pkgrel=1
pkgdesc='An interactive shell to connect with MongoDB with syntax highlighting, autocomplete, contextual help and error messages.'
arch=('x86_64' 'aarch64')
@@ -15,17 +15,17 @@ license=('Apache')
_mongosh_folder=mongosh-${pkgver}-linux
source_x86_64=("https://downloads.mongodb.com/compass/${_pkgname}-${pkgver}-linux-x64.tgz")
-sha256sums_x86_64=('cccab6a6194cc8b8a27c754f1a3c02d8379726c47ce5a923a2027391c94fe784')
source_aarch64=("https://downloads.mongodb.com/compass/${_pkgname}-${pkgver}-linux-arm64.tgz")
-sha256sums_aarch64=('2e40cd44b238feef335c6f0b969966dfe1e77fbdffcc8244c5e8ed78788a6de2')
+sha256sums_x86_64=('5f0facb8ec2e76e722cff44d97ee6f5823d572f754e212709c3015ae0f9221ed')
+sha256sums_aarch64=('336219b676a54391e21c28c1228c4abe9622c2b7ef762471ed4f58c29dd35634')
package() {
- if [ $CARCH = 'x86_64' ]; then
- _arch=x64;
- elif [ $CARCH = 'aarch64' ]; then
- _arch=arm64;
- fi
- install -D $_mongosh_folder-${_arch}/bin/mongosh "$pkgdir/usr/bin/mongosh"
- install -D $_mongosh_folder-${_arch}/bin/mongosh_crypt_v1.so "$pkgdir/usr/lib/mongosh_crypt_v1.so"
- install -Dm644 $_mongosh_folder-${_arch}/mongosh.1.gz "$pkgdir/usr/share/man/man1/mongosh.1.gz"
+ if [ $CARCH = 'x86_64' ]; then
+ _arch=x64;
+ elif [ $CARCH = 'aarch64' ]; then
+ _arch=arm64;
+ fi
+ install -D $_mongosh_folder-${_arch}/bin/mongosh "$pkgdir/usr/bin/mongosh"
+ install -D $_mongosh_folder-${_arch}/bin/mongosh_crypt_v1.so "$pkgdir/usr/lib/mongosh_crypt_v1.so"
+ install -Dm644 $_mongosh_folder-${_arch}/mongosh.1.gz "$pkgdir/usr/share/man/man1/mongosh.1.gz"
}