summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-05-22 17:28:07 +0200
committerGoliathLabs2020-05-22 17:28:07 +0200
commit3e2b5720ed51b35bfbefd265bf96b0f5455a791d (patch)
tree4a5e80021b6cc1ac9703f0faf7686abf4ba3a88b
parentc17a84070b012b40d8ef0b8e7e8ba4265c1a7a71 (diff)
downloadaur-monodevelop-stable.tar.gz
Updated: PKGBUILD
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD47
2 files changed, 38 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5f83fc85ddc..16f45d508dfc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,25 @@
pkgbase = monodevelop-stable
pkgdesc = An IDE primarily designed for C# and other .NET languages
pkgver = 8.4.3.12
- pkgrel = 1
- url = http://www.monodevelop.com
- arch = x86_64
- arch = i686
- license = GPL
+ pkgrel = 2
+ url = https://www.monodevelop.com
+ arch = any
+ license = MIT
makedepends = rsync
- makedepends = cmake
makedepends = git
makedepends = nuget
- makedepends = openssl-1.0
- makedepends = xterm
- makedepends = pkgconf
- makedepends = autoconf
- makedepends = automake
- depends = mono>=5.10.1.47
- depends = mono-addins>=0.6.2
- depends = gtk-sharp-2
+ makedepends = referenceassemblies-pcl
+ depends = mono5
+ depends = mono-addins
+ depends = gnome-sharp
+ depends = hicolor-icon-theme
+ depends = mono-tools
+ depends = fsharp
+ depends = cmake
depends = libssh2
+ depends = http-parser
depends = curl
+ depends = dotnet-host
depends = msbuild-stable
optdepends = xsp: To run ASP.NET pages directly from monodevelop
provides = monodevelop
@@ -27,7 +27,7 @@ pkgbase = monodevelop-stable
conflicts = monodevelop
replaces = monodevelop-debugger-gdb
options = !makeflags
- source = git://github.com/mono/monodevelop.git#tag=monodevelop-8.4.3.12
+ source = git+https://github.com/mono/monodevelop.git#tag=monodevelop-8.4.3.12
sha256sums = SKIP
pkgname = monodevelop-stable
diff --git a/PKGBUILD b/PKGBUILD
index d243b9634b26..c1340aade1f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,50 +10,49 @@
pkgname=monodevelop-stable
_pkgname=monodevelop
pkgver=8.4.3.12
-pkgrel=1
+pkgrel=2
pkgdesc="An IDE primarily designed for C# and other .NET languages"
-arch=('x86_64' 'i686')
-url="http://www.monodevelop.com"
-license=('GPL')
-depends=('mono>=5.10.1.47' 'mono-addins>=0.6.2' 'gtk-sharp-2' 'libssh2' 'curl' 'msbuild-stable')
-makedepends=('rsync' 'cmake' 'git' 'nuget' 'openssl-1.0' 'xterm' 'pkgconf' 'autoconf' 'automake')
+arch=('any')
+url="https://www.monodevelop.com"
+license=('MIT')
+depends=('mono5' 'mono-addins' 'gnome-sharp' 'hicolor-icon-theme' 'mono-tools' 'fsharp' 'cmake' 'libssh2' 'http-parser' 'curl' 'dotnet-host' 'msbuild-stable')
+makedepends=('rsync' 'git' 'nuget' 'referenceassemblies-pcl')
replaces=('monodevelop-debugger-gdb')
provides=('monodevelop' 'monodevelop-debugger-gdb')
conflicts=('monodevelop')
options=(!makeflags)
optdepends=('xsp: To run ASP.NET pages directly from monodevelop')
-source=(git://github.com/mono/monodevelop.git#tag=monodevelop-$pkgver)
+
+source=(git+https://github.com/mono/monodevelop.git#tag=monodevelop-$pkgver)
sha256sums=('SKIP')
-TERM=xterm
-SHELL=/bin/bash
prepare() {
- cd $_pkgname
- git submodule update --init --recursive || return 1
- git checkout tags/$_pkgname-$pkgver
- git clean -dfx
+ cd ${srcdir}/$_pkgname
+ sed -i -e "s/MonoDevelop.FSharp.Shared.ToolTip /MonoDevelop.FSharp.Shared.ToolTips.ToolTip /" main/external/fsharpbinding/MonoDevelop.FSharpBinding FSharpTextEditorCompletion.fs
+ sed -i -e "s/MonoDevelop.FSharp.Shared.EmptyTip /MonoDevelop.FSharp.Shared.ToolTips.EmptyTip /" main/external/fsharpbinding/MonoDevelop.FSharpBinding FSharpTextEditorCompletion.fs
}
build() {
- cd $_pkgname
+ export MONO_SHARED_DIR=$srcdir/src/.wabi
+ mkdir -p $MONO_SHARED_DIR
- export PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig
- export CFLAGS+=" -I/usr/include/openssl-1.0"
- export LDFLAGS+=" -L/usr/lib/openssl-1.0 -lssl"
- export MONO_IOMAP=all
+ cd ${srcdir}/$_pkgname
+ git submodule update --init --recursive || return 1
+ git checkout tags/$_pkgname-$pkgver
+ git clean -dfx
./configure --prefix=/usr --profile=gnome
- XDG_CONFIG_HOME="$srcdir"/config make
+ XDG_CONFIG_HOME="$srcdir"/config LD_PRELOAD="" make
}
package() {
- cd $_pkgname
+ cd ${srcdir}/$_pkgname
XDG_CONFIG_HOME="$srcdir"/config LD_PRELOAD="" make DESTDIR="$pkgdir" install
# delete conflicting files
- find "$pkgdir"/usr/share/mime/ -type f -delete
+ rm -r $(find $pkgdir/usr/share/mime/ -type f | grep -v "packages")
+ rm -r $MONO_SHARED_DIR
- #Correct Invalid Env Paths in static launcher
- sed -i "s/export LD_LIBRARY_PATH.*/export LD_LIBRARY_PATH\=\"\/usr\/lib\/monodevelop\/bin\:\$\{LD_LIBRARY_PATH\}\"/g" $pkgdir/usr/bin/monodevelop;
- sed -i "s/EXE_PATH=.*/EXE_PATH=\/usr\/lib\/monodevelop\/bin\/MonoDevelop.exe/g" $pkgdir/usr/bin/monodevelop;
+ # NuGet.exe is missing somehow, fixed FS#43423
+ install -Dm755 "${srcdir}"/monodevelop/main/external/nuget-binary/nuget.exe "${pkgdir}"/usr/lib/monodevelop/AddIns/MonoDevelop.PackageManagement/NuGet.exe
}