summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSplith2018-01-11 21:29:57 +0000
committerSplith2018-01-11 21:29:57 +0000
commit272925ee8bbdc00fa4e8d20c3545ba1758786467 (patch)
tree030f0b91567ef6cce5d17cd3eb95196a3334ed8d
downloadaur-mosquitto-php.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52da9d8bca53
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mosquitto-php
+ pkgdesc = MQTT (Mosquitto) PHP extension
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://github.com/mgdm/Mosquitto-PHP
+ arch = any
+ license = BSD
+ makedepends = php
+ makedepends = mosquitto
+ depends = php
+ depends = mosquitto
+ backup = etc/php/conf.d/mosquitto.ini
+ source = git+https://github.com/mgdm/mosquitto-php.git
+ sha256sums = SKIP
+
+pkgname = mosquitto-php
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..17346feb72db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Mantainer: Splith <spam at helper3000 net>
+# Package version 0.4.1 commit: ba7c5e0209f74b1622e8dc57f3ccfe97863406c4
+
+pkgname=mosquitto-php
+pkgver=0.4.1
+pkgrel=1
+pkgdesc='MQTT (Mosquitto) PHP extension'
+url='https://github.com/mgdm/Mosquitto-PHP'
+license=('BSD')
+arch=('any')
+depends=('php' 'mosquitto')
+makedepends=('php' 'mosquitto')
+source=("git+https://github.com/mgdm/mosquitto-php.git")
+backup=('etc/php/conf.d/mosquitto.ini')
+sha256sums=('SKIP')
+
+build() {
+ cd $srcdir/mosquitto-php
+
+ msg "Running phpize..."
+ phpize
+ ./configure --prefix=/usr --with-mosquitto=/usr/lib/libmosquitto.so
+
+ msg "Building extension..."
+ make
+}
+
+package() {
+ cd $srcdir/mosquitto-php
+ msg "Installing files..."
+ mkdir -p "$pkgdir"/{/usr/lib/php/modules,/etc/php/conf.d}
+ mkdir -p "$pkgdir"/usr/share/licenses/mosquitto-php
+
+ echo "extension=mosquitto.so" > "mosquitto.ini"
+
+ install -D -m755 modules/mosquitto.so ${pkgdir}/usr/lib/php/modules/mosquitto.so
+ install -D -m644 mosquitto.ini ${pkgdir}/etc/php/conf.d/mosquitto.ini
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/mosquitto-php/LICENSE
+}