summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Heinrich2018-03-23 16:26:36 +0100
committerJonas Heinrich2018-03-23 16:26:36 +0100
commitcd251f44490b32ec7f1a40d2f9353b2105300156 (patch)
tree3faff892101da7b20a9631f3bcb4bc497917e009
downloadaur-mozilla-firefox-account-server.tar.gz
first commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9dd86ef1cdfe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Fri Mar 23 15:26:26 UTC 2018
+pkgbase = mozilla-firefox-account-server
+ pkgdesc = Firefox Accounts authentication server
+ pkgver = 1.108.0
+ pkgrel = 1
+ url = https://github.com/mozilla/fxa-auth-server
+ arch = any
+ license = MPL2
+ depends = npm
+ depends = nodejs
+ optdepends = mozilla-firefox-sync-server: Mozilla Sync Server for built-in Firefox Sync
+ source = mozilla-firefox-account-server-1.108.0.tar.gz::https://github.com/mozilla/fxa-auth-server/archive/v1.108.0.tar.gz
+ sha512sums = d84885052aa5b7f53098cc3a7b22a0b082123dc4e22c6f5d9c4bca8a79500253b0d90558a2fe29d677ee50776a2161a4e47dcb95b038612851f8c1dbf09ffd21
+
+pkgname = mozilla-firefox-account-server
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c8c86c36ed9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Jonas Heinrich <onny@project-insanity.org>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+
+pkgname=mozilla-firefox-account-server
+pkgver=1.108.0
+pkgrel=1
+pkgdesc="Firefox Accounts authentication server"
+arch=('any')
+url='https://github.com/mozilla/fxa-auth-server'
+license=('MPL2')
+depends=('npm' 'nodejs')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/mozilla/fxa-auth-server/archive/v${pkgver}.tar.gz")
+sha512sums=('d84885052aa5b7f53098cc3a7b22a0b082123dc4e22c6f5d9c4bca8a79500253b0d90558a2fe29d677ee50776a2161a4e47dcb95b038612851f8c1dbf09ffd21')
+optdepends=('mozilla-firefox-sync-server: Mozilla Sync Server for built-in Firefox Sync')
+
+build() {
+ cd "fxa-auth-server-${pkgver}"
+ npm install
+}
+
+package() {
+ cd "fxa-auth-server-${pkgver}"
+}
+
+# vim: ft=sh syn=sh ts=2 sw=2 et: