summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarius Orcsik2022-04-13 09:47:44 +0200
committerMarius Orcsik2022-04-13 09:47:44 +0200
commit68cf7c4f793fcc00b0fe99c86b1d6bf8f1414d35 (patch)
treedacb8664828b117972779f5d70caa6ae9d6ca718
parent1537ca99e2660b81f82d412b9f23d069f733b703 (diff)
downloadaur-68cf7c4f793fcc00b0fe99c86b1d6bf8f1414d35.tar.gz
Updated to v0.4.90 which fixes curl issues
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6f8ed77fc12..f440e50ecb29 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mpris-scrobbler
pkgdesc = Minimalistic user daemon which submits the currently playing song to libre.fm and compatible services.
- pkgver = 0.4.0.1
+ pkgver = 0.4.90
pkgrel = 1
url = https://github.com/mariusor/mpris-scrobbler
arch = x86
@@ -18,9 +18,8 @@ pkgbase = mpris-scrobbler
depends = curl
depends = json-c
optdepends = scdoc
- source = mpris-scrobbler-0.4.0.1.tar.gz::https://github.com/mariusor/mpris-scrobbler/archive/v0.4.0.1.tar.gz
+ source = mpris-scrobbler-0.4.90.tar.gz::https://github.com/mariusor/mpris-scrobbler/archive/v0.4.90.tar.gz
validpgpkeys = 57D7D1ACC58E01C56961F9FB0FBA983067613EE6
- sha256sums = 16d2a75437afd7c4f032f5771da7b1bcbec5d204003369cf71ab928c04119e04
+ sha256sums = eb41baf670dd82925ce002c9e7f2e7f6b28188afad60a61701b20b7ee7d070f3
pkgname = mpris-scrobbler
-
diff --git a/PKGBUILD b/PKGBUILD
index 59225743c78d..254ebf9db3d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Marius Orcsik <marius@littr.me>
pkgname=mpris-scrobbler
-pkgver=0.4.0.1
+pkgver=0.4.90
pkgrel=1
pkgdesc="Minimalistic user daemon which submits the currently playing song to libre.fm and compatible services."
arch=('x86' 'x86_64')
@@ -11,12 +11,13 @@ depends=('dbus>=1.9' 'libevent' 'curl' 'json-c')
optdepends=('scdoc')
source=("$pkgname-$pkgver.tar.gz::https://github.com/mariusor/$pkgname/archive/v$pkgver.tar.gz")
validpgpkeys=('57D7D1ACC58E01C56961F9FB0FBA983067613EE6')
-sha256sums=('16d2a75437afd7c4f032f5771da7b1bcbec5d204003369cf71ab928c04119e04')
+sha256sums=('eb41baf670dd82925ce002c9e7f2e7f6b28188afad60a61701b20b7ee7d070f3')
build() {
cd "$pkgname-$pkgver"
rm -rf build/
- meson -Dbuildtype=release --strip -Db_pie=true -Db_ndebug=if-release -Db_lto=true -Db_asneeded=true -Dversion=${pkgver}-${pkgrel} --prefix=/usr --unity on build/
+ export CFLAGS='-Wno-unused-parameter -Wno-free-nonheap-object -Wno-format-truncation'
+ meson -Dbuildtype=release -Db_pie=true -Db_ndebug=if-release -Dversion=${pkgver}-${pkgrel} --prefix=/usr --unity on build/
ninja -C build/
}