summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Sequeira2018-01-26 23:40:04 -0500
committerPhilip Sequeira2018-01-26 23:40:04 -0500
commit8153d5c168396948abefd608b250f2ebc2a16e08 (patch)
tree7fed72245868b21799622622b06cabe2a2eb21fa
parentbc3ac332ee6eba36dcade8016c2260762459ae87 (diff)
downloadaur-8153d5c168396948abefd608b250f2ebc2a16e08.tar.gz
add vulkan-headers to makedepends if vulkan.pc is installed
This fixes a build failure that several users have experienced due to a weird package situation. See the comment+link in PKGBUILD for details.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1565667a4965..c0d91e054b7e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Dec 6 04:23:12 UTC 2017
+# Sat Jan 27 04:39:04 UTC 2018
pkgbase = mpv-git
pkgdesc = Video player based on MPlayer/mplayer2 (git version)
- pkgver = 0.27.0_495_g0433162f7f
+ pkgver = 0.28.0_169_g7eb3427573
pkgrel = 1
url = https://mpv.io
install = mpv.install
diff --git a/PKGBUILD b/PKGBUILD
index c4375ed00b61..1e1d76cbbbf2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -48,7 +48,7 @@ _opt_features=(
pkgname=mpv-git
_gitname=mpv
-pkgver=0.27.0_495_g0433162f7f
+pkgver=0.28.0_169_g7eb3427573
pkgrel=1
pkgdesc='Video player based on MPlayer/mplayer2 (git version)'
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
@@ -69,6 +69,17 @@ md5sums=('SKIP'
sha256sums=('SKIP'
'ce974e160347202e0dc63f6a7a5a89e52d2cc1db2d000c661fddb9dc1d007c02')
+# vulkan-icd-loader contains vulkan.pc, which makes mpv think it can build
+# against Vulkan. However, the headers required to actually do so are in another
+# package, vulkan-headers, for whatever reason. Building with only the former
+# installed will fail. So if we see the .pc installed, make sure the headers are
+# too.
+#
+# See also: https://bugs.archlinux.org/task/56238
+if pkg-config --exists vulkan; then
+ makedepends+=('vulkan-headers')
+fi
+
_opt_extra_flags=()
for feature in "${_opt_features[@]}"; do