summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Sequeira2018-08-13 23:10:40 -0400
committerPhilip Sequeira2018-08-13 23:10:40 -0400
commite6cbbce32ba310da8508226879b3fc8d91ca8e5d (patch)
tree85b87d769c7f86389782539c1772a9902e1e257b
parent4fc902051a0d0f1b6e8ba61c77143367fe5367f3 (diff)
downloadaur-e6cbbce32ba310da8508226879b3fc8d91ca8e5d.tar.gz
download waf as a makepkg source
This allows building without network, caching the waf download even when doing a clean build, and is cleaner semantically in general. We still run mpv's bootstrap script, but we now tell it not to attempt the download. It will simply check that the waf version it expects is present. If that check fails, it will bail and the PKGBUILD will have to be updated.
-rw-r--r--.SRCINFO8
-rwxr-xr-x[-rw-r--r--]PKGBUILD14
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f00a23ebd74..3cf4be9b473d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed May 30 23:47:33 UTC 2018
+# Tue Aug 14 03:08:32 UTC 2018
pkgbase = mpv-git
pkgdesc = Video player based on MPlayer/mplayer2 (git version)
- pkgver = 0.28.0_605_gcb52cfae1a
+ pkgver = 0.29.0_19_g6c2d6a3046
pkgrel = 1
url = https://mpv.io
install = mpv.install
@@ -22,10 +22,10 @@ pkgbase = mpv-git
options = !emptydirs
source = git+https://github.com/mpv-player/mpv
source = find-deps.py
- md5sums = SKIP
- md5sums = ffb774b13decbefc62908dda0332046b
+ source = https://waf.io/waf-2.0.9
sha256sums = SKIP
sha256sums = ce974e160347202e0dc63f6a7a5a89e52d2cc1db2d000c661fddb9dc1d007c02
+ sha256sums = 2a8e0816f023995e557f79ea8940d322bec18f286917c8f9a6fa2dc3875dfa48
pkgname = mpv-git
diff --git a/PKGBUILD b/PKGBUILD
index 43890a335429..004787e8f353 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -48,8 +48,9 @@ _opt_features=(
pkgname=mpv-git
_gitname=mpv
-pkgver=0.28.0_605_gcb52cfae1a
+pkgver=0.29.0_19_g6c2d6a3046
pkgrel=1
+_waf_version=2.0.9
pkgdesc='Video player based on MPlayer/mplayer2 (git version)'
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
license=('GPL')
@@ -63,11 +64,11 @@ conflicts=('mpv')
options=('!emptydirs')
install=mpv.install
source=('git+https://github.com/mpv-player/mpv'
- 'find-deps.py')
-md5sums=('SKIP'
- 'ffb774b13decbefc62908dda0332046b')
+ 'find-deps.py'
+ "https://waf.io/waf-${_waf_version}")
sha256sums=('SKIP'
- 'ce974e160347202e0dc63f6a7a5a89e52d2cc1db2d000c661fddb9dc1d007c02')
+ 'ce974e160347202e0dc63f6a7a5a89e52d2cc1db2d000c661fddb9dc1d007c02'
+ '2a8e0816f023995e557f79ea8940d322bec18f286917c8f9a6fa2dc3875dfa48')
# vulkan-icd-loader contains vulkan.pc, which makes mpv think it can build
# against Vulkan. However, the headers required to actually do so are in another
@@ -141,7 +142,8 @@ pkgver() {
prepare() {
cd "$srcdir/$_gitname"
- ./bootstrap.py
+ install -m755 "${srcdir}/waf-${_waf_version}" waf
+ ./bootstrap.py --no-download
}
build() {