summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Sequeira2017-10-30 19:59:07 -0400
committerPhilip Sequeira2017-10-30 19:59:07 -0400
commitf9e2bdd2d3fa36272f9841975fa730d52affcd3e (patch)
tree9b2ee4ff340c65a91905d5e4ef28ad7640be2139
parent26af1fc9fb7b1437049119b1019a1c9c45634df9 (diff)
downloadaur-f9e2bdd2d3fa36272f9841975fa730d52affcd3e.tar.gz
update ffmpeg workaround
Can't just revert the commit anymore, as the surrounding code has changed since. Add a patch with a simple workaround that will hopefully not break too often. PR #5033 has been merged(ish) upstream. Remove the patch. mpv now requires git master ffmpeg; the latest release is not new enough. This package probably should start depending on ffmpeg-git, but I'm not switching it yet because that isn't provided by the current ffmpeg-mpv-git package. We'll just live with the _dirty in the version for now. If this goes on, I'll strip it from the pkgver, but it will stay in the built binary as long as it's true, to respect those handling bug reports upstream. Some kind of option to avoid applying the patch when using ffmpeg-mpv should be doable, though, so those who are following upstream's recommendations can get a fully supported build without -dirty.
-rw-r--r--.SRCINFO10
-rw-r--r--5033.patch26
-rw-r--r--PKGBUILD12
-rw-r--r--allow-upstream-ffmpeg.patch13
4 files changed, 23 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e707b4cd2ea3..90d556a4f174 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Oct 28 02:30:42 UTC 2017
+# Mon Oct 30 23:56:12 UTC 2017
pkgbase = mpv-git
pkgdesc = Video player based on MPlayer/mplayer2 (git version)
- pkgver = 0.27.0_310_ga00a2266a0
+ pkgver = 0.27.0_322_g0b8b64fba3_dirty
pkgrel = 1
url = https://mpv.io
install = mpv.install
@@ -20,13 +20,13 @@ pkgbase = mpv-git
conflicts = mpv
options = !emptydirs
source = git+https://github.com/mpv-player/mpv
- source = 5033.patch
+ source = allow-upstream-ffmpeg.patch
source = find-deps.py
md5sums = SKIP
- md5sums = 2292f053f7e2e5a32fcf778746c25265
+ md5sums = dcc4e3bd6722b120d13d0dc9b6e6a791
md5sums = ffb774b13decbefc62908dda0332046b
sha256sums = SKIP
- sha256sums = 8d46d9ba280a48248f28feeb3d2ff28a16dbd0a5eea8d9178756590de9e3e421
+ sha256sums = 93f92ac06e815d2eaedacb161b57e2d68086566bf2c9942dd6fc0ad16dc71272
sha256sums = ce974e160347202e0dc63f6a7a5a89e52d2cc1db2d000c661fddb9dc1d007c02
pkgname = mpv-git
diff --git a/5033.patch b/5033.patch
deleted file mode 100644
index b0db55ba6c8b..000000000000
--- a/5033.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 2b330cc60e1841f18512a99b52e25732725b886f Mon Sep 17 00:00:00 2001
-From: Daniel Kucera <daniel.kucera@gmail.com>
-Date: Mon, 23 Oct 2017 15:29:17 +0200
-Subject: [PATCH] demux_lavf: return AVERROR_EOF on file end
-
-Signed-off-by: Daniel Kucera <daniel.kucera@gmail.com>
----
- demux/demux_lavf.c | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/demux/demux_lavf.c b/demux/demux_lavf.c
-index 53bf62016a..214e0c297f 100644
---- a/demux/demux_lavf.c
-+++ b/demux/demux_lavf.c
-@@ -242,7 +242,10 @@ static int mp_read(void *opaque, uint8_t *buf, int size)
-
- MP_TRACE(demuxer, "%d=mp_read(%p, %p, %d), pos: %"PRId64", eof:%d\n",
- ret, stream, buf, size, stream_tell(stream), stream->eof);
-- return ret;
-+ if (stream->eof)
-+ return AVERROR_EOF;
-+ else
-+ return ret;
- }
-
- static int64_t mp_seek(void *opaque, int64_t pos, int whence)
diff --git a/PKGBUILD b/PKGBUILD
index e30790bff638..a0baf9a252a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -48,7 +48,7 @@ _opt_features=(
pkgname=mpv-git
_gitname=mpv
-pkgver=0.27.0_310_ga00a2266a0
+pkgver=0.27.0_322_g0b8b64fba3_dirty
pkgrel=1
pkgdesc='Video player based on MPlayer/mplayer2 (git version)'
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
@@ -63,13 +63,13 @@ conflicts=('mpv')
options=('!emptydirs')
install=mpv.install
source=('git+https://github.com/mpv-player/mpv'
- '5033.patch'
+ 'allow-upstream-ffmpeg.patch'
'find-deps.py')
md5sums=('SKIP'
- '2292f053f7e2e5a32fcf778746c25265'
+ 'dcc4e3bd6722b120d13d0dc9b6e6a791'
'ffb774b13decbefc62908dda0332046b')
sha256sums=('SKIP'
- '8d46d9ba280a48248f28feeb3d2ff28a16dbd0a5eea8d9178756590de9e3e421'
+ '93f92ac06e815d2eaedacb161b57e2d68086566bf2c9942dd6fc0ad16dc71272'
'ce974e160347202e0dc63f6a7a5a89e52d2cc1db2d000c661fddb9dc1d007c02')
_opt_extra_flags=()
@@ -135,9 +135,7 @@ prepare() {
cd "$srcdir/$_gitname"
./bootstrap.py
- # Temporary workaround (see AUR comments)
- git revert --no-edit 83d44aca7dc7f46b8d3b64d441f5a8317a40e080
- git am "$srcdir/5033.patch"
+ git apply "$srcdir/allow-upstream-ffmpeg.patch"
}
build() {
diff --git a/allow-upstream-ffmpeg.patch b/allow-upstream-ffmpeg.patch
new file mode 100644
index 000000000000..90523b4567c9
--- /dev/null
+++ b/allow-upstream-ffmpeg.patch
@@ -0,0 +1,13 @@
+diff --git a/wscript b/wscript
+index 5a389f16f2..7c30b9fe6e 100644
+--- a/wscript
++++ b/wscript
+@@ -484,7 +484,7 @@ libav_dependencies = [
+ }, {
+ 'name': 'libav-any',
+ 'desc': 'Libav/FFmpeg library versions',
+- 'deps': 'ffmpeg_mpv || libav',
++ 'deps': 'ffmpeg_mpv || libav || ffmpeg_garbage',
+ 'func': check_ffmpeg_or_libav_versions(),
+ 'req': True,
+ 'fmsg': "Unable to find development files for some of the required \