summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEthan Kerrick2021-10-03 20:38:54 -0400
committerEthan Kerrick2021-10-03 20:38:54 -0400
commit08be9ecd6365b5b7bb9c7ce287dffb26a2ef17fe (patch)
tree50a0cd30ceac78ad76332bc487c122148799dc8d
parent2614defd8e15a790bb5c95cf0768c3a9a0fd8757 (diff)
downloadaur-mse-extrafoils.tar.gz
bumped to 2.1.2 with new foils add
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 43 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e8aa1a703ed..b33045fa3727 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = mse-extrafoils
pkgdesc = Various extra foils for MSE.
- pkgver = 2.0.0
- pkgrel = 3
+ pkgver = 2.1.2
+ pkgrel = 1
url = http://msetemps.sourceforge.net/phpBB3/viewtopic.php?&t=144
arch = any
groups = mse-addons
groups = mse-addons-foils
license = GPL
depends = magicseteditor
- source = https://downloads.sourceforge.net/msetemps/Magic%20-%20Overlays.mse-installer
- sha256sums = 9290cec200846ad9133336a95acb97b5965a024fef9243b47001ba6a8626a09d
+ source = https://github.com/silverhikari/magic-set-templates-aur/raw/main/2.1.2-extrafoils.tar.gz
+ sha256sums = 2be5caca81465965cac576375e444a1174c1a116d5e3f5f2c8bb084b72e5b163
pkgname = mse-extrafoils-clights
pkgdesc = Various extra foils for MSE. This one is the Christmas Lights object gradient by Art_Freak.
@@ -49,3 +49,11 @@ pkgname = mse-extrafoils-ribbon
pkgname = mse-extrafoils-ripples
pkgdesc = Various extra foils for MSE. This one is the ripples foil gradient.
+pkgname = mse-extrafoils-holes
+ pkgdesc = Various extra foils for MSE. This one is the holes foil gradient.
+
+pkgname = mse-extrafoils-normal
+ pkgdesc = Various extra foils for MSE. This one is the normal foil gradient.
+
+pkgname = mse-extrafoils-oldfeed
+ pkgdesc = Various extra foils for MSE. This one is the oldfeed foil gradient.
diff --git a/PKGBUILD b/PKGBUILD
index d3da42d89e56..54e0492d80e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
-# Contributor: Sapphira Armageddos <shadowkyogre.public@gmail.com>
+# Maintainer: Sapphira Armageddos <shadowkyogre.public@gmail.com>
+# Maintainer: silverhikari
pkgbase=mse-extrafoils
-pkgname=("${pkgbase}-clights" "${pkgbase}-fire" "${pkgbase}-fracture" "${pkgbase}-ghost" "${pkgbase}-insanity" "${pkgbase}-jss" "${pkgbase}-oil" "${pkgbase}-old" "${pkgbase}-parallel" "${pkgbase}-polishedstone" "${pkgbase}-ribbon" "${pkgbase}-ripples")
-pkgver=2.0.0
-pkgrel=3
+pkgname=("${pkgbase}-clights" "${pkgbase}-fire" "${pkgbase}-fracture" "${pkgbase}-ghost" "${pkgbase}-insanity" "${pkgbase}-jss" "${pkgbase}-oil" "${pkgbase}-old" "${pkgbase}-parallel" "${pkgbase}-polishedstone" "${pkgbase}-ribbon" "${pkgbase}-ripples" "${pkgbase}-holes" "${pkgbase}-normal" "${pkgbase}-oldfeed")
+pkgver=2.1.2
+pkgrel=1
pkgdesc="Various extra foils for MSE."
arch=(any)
url="http://msetemps.sourceforge.net/phpBB3/viewtopic.php?&t=144"
license=('GPL')
depends=('magicseteditor')
groups=('mse-addons' 'mse-addons-foils')
-source=('https://downloads.sourceforge.net/msetemps/Magic%20-%20Overlays.mse-installer')
-sha256sums=('9290cec200846ad9133336a95acb97b5965a024fef9243b47001ba6a8626a09d')
+source=('https://github.com/silverhikari/magic-set-templates-aur/raw/main/2.1.2-extrafoils.tar.gz')
+sha256sums=('2be5caca81465965cac576375e444a1174c1a116d5e3f5f2c8bb084b72e5b163')
_package-clights() {
pkgdesc="${pkgdesc} This one is the Christmas Lights object gradient by Art_Freak."
@@ -100,6 +101,30 @@ _package-ripples() {
cp -r "magic-overlay-foil-${pkgname#${pkgbase}-}.mse-include" "$pkgdir/usr/share/magicseteditor/data"
}
+_package-normal() {
+ pkgdesc="${pkgdesc} This one is the normal foil gradient."
+
+ cd "$srcdir"
+ mkdir -p "$pkgdir/usr/share/magicseteditor/data"
+ cp -r "magic-overlay-foil-${pkgname#${pkgbase}-}.mse-include" "$pkgdir/usr/share/magicseteditor/data"
+}
+
+_package-holes() {
+ pkgdesc="${pkgdesc} This one is the holes foil gradient."
+
+ cd "$srcdir"
+ mkdir -p "$pkgdir/usr/share/magicseteditor/data"
+ cp -r "magic-overlay-foil-${pkgname#${pkgbase}-}.mse-include" "$pkgdir/usr/share/magicseteditor/data"
+}
+
+_package-oldfeed() {
+ pkgdesc="${pkgdesc} This one is the oldfeed foil gradient."
+
+ cd "$srcdir"
+ mkdir -p "$pkgdir/usr/share/magicseteditor/data"
+ cp -r "magic-overlay-foil-${pkgname#${pkgbase}-}.mse-include" "$pkgdir/usr/share/magicseteditor/data"
+}
+
for _p in ${pkgname[@]};do
eval "package_${_p}() {
$(declare -f "_package${_p#${pkgbase}}")