summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Ivanov2019-09-25 19:04:46 +0200
committerPeter Ivanov2019-09-25 19:04:46 +0200
commit957f89d5d110776ff4cee50e5844a9c0c12cf865 (patch)
treeeb03a9ea9ee0b979f6862bd9020e8eb3fb5d70b4
parentddb7e6757e5bf5ef789945abc73c83c8f1f71e42 (diff)
downloadaur-957f89d5d110776ff4cee50e5844a9c0c12cf865.tar.gz
Adapted to version 8.2.0.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD59
2 files changed, 39 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a8d390df17e..1218f8b9adc5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mspgcc-ti
pkgdesc = GNU toolchain (as, gcc, g++, ld, gdb) for the TI MSP430 processor
- pkgver = 6.1.1.0
+ pkgver = 8.2.0.0
pkgrel = 1
url = http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/latest/index_FDS.html
install = mspgcc-ti.install
@@ -15,11 +15,13 @@ pkgbase = mspgcc-ti
options = !libtool
options = staticlibs
source = mspgcc-ti.sh
+ source = http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/latest/exports/msp430-gcc-support-files-1.207.zip
sha1sums = a4a81f1b041bf39c3f9c75d94c22d149d1ceee9e
- source_i686 = http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/6_1_1_0/exports/msp430-gcc-full-linux-installer-6.1.1.0.run
- sha1sums_i686 = e62f6300f4107f9048e6ceef044d6d58cdec6c60
- source_x86_64 = http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/6_1_1_0/exports/msp430-gcc-full-linux-x64-installer-6.1.1.0.run
- sha1sums_x86_64 = ab021902ca3730760723df366daf40ba8d6950ae
+ sha1sums = ba0f1ae658ad6010ab0c9c1b2e43958e254a3ea0
+ source_i686 = http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/8_2_0_0/exports/msp430-gcc-8.2.0.52_linux32.tar.bz2
+ sha1sums_i686 = 14a44312a1b2dd5c505459f0332278a9e5f5fe32
+ source_x86_64 = http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/8_2_0_0/exports/msp430-gcc-8.2.0.52_linux64.tar.bz2
+ sha1sums_x86_64 = 2fef899a98c8e3e85b186fcd94df2f317a82eb5d
pkgname = mspgcc-ti
diff --git a/PKGBUILD b/PKGBUILD
index 0f73c50d7c43..bfef7017ebfd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Peter Ivanov <ivanovp@gmail.com>
pkgname=mspgcc-ti
-pkgver=6.1.1.0
+pkgver=8.2.0.0
pkgrel=1
pkgdesc="GNU toolchain (as, gcc, g++, ld, gdb) for the TI MSP430 processor"
arch=('i686' 'x86_64')
@@ -11,41 +11,46 @@ depends=('elfutils' 'libmpc' 'zlib')
options=(!strip !emptydirs !libtool staticlibs)
PKGEXT=".pkg.tar"
install=mspgcc-ti.install
-_installer=msp430-gcc-full-linux-installer-6.1.1.0.run
-_installer_x64=msp430-gcc-full-linux-x64-installer-6.1.1.0.run
-source=("${pkgname}.sh")
-source_i686=("http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/6_1_1_0/exports/$_installer")
-source_x86_64=("http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/6_1_1_0/exports/$_installer_x64")
-sha1sums=('a4a81f1b041bf39c3f9c75d94c22d149d1ceee9e')
-sha1sums_i686=('e62f6300f4107f9048e6ceef044d6d58cdec6c60')
-sha1sums_x86_64=('ab021902ca3730760723df366daf40ba8d6950ae')
-_install_dir=/opt/ti/mspgcc
-
-build() {
- if test "$CARCH" == x86_64; then
- chmod +x $_installer_x64
- else
- chmod +x $_installer
- fi
-}
+#http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/latest/exports/msp430-gcc-8.2.0.52_linux64.tar.bz2
+_tarbz2=msp430-gcc-8.2.0.52_linux32.tar.bz2
+_tarbz2_x64=msp430-gcc-8.2.0.52_linux64.tar.bz2
+_zip=msp430-gcc-support-files-1.207.zip
+source=("${pkgname}.sh"
+ "http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/latest/exports/$_zip")
+source_i686=("http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/8_2_0_0/exports/$_tarbz2")
+source_x86_64=("http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/8_2_0_0/exports/$_tarbz2_x64")
+sha1sums=('a4a81f1b041bf39c3f9c75d94c22d149d1ceee9e'
+ 'ba0f1ae658ad6010ab0c9c1b2e43958e254a3ea0')
+sha1sums_i686=('14a44312a1b2dd5c505459f0332278a9e5f5fe32')
+sha1sums_x86_64=('2fef899a98c8e3e85b186fcd94df2f317a82eb5d')
+_install_dir=/opt/ti
package() {
- msg "Running TI's installer..."
+ msg "Extracting compiler..."
+ mkdir -p $pkgdir$_install_dir
+ cd $pkgdir$_install_dir
if test "$CARCH" == x86_64; then
- ${srcdir}/$_installer_x64 --mode unattended --prefix $pkgdir$_install_dir
+ tar xjf ${srcdir}/$_tarbz2_x64
+ ln -s msp430-gcc-8.2.0.52_linux64 $pkgdir$_install_dir/mspgcc
else
- ${srcdir}/$_installer --mode unattended --prefix $pkgdir$_install_dir
+ tar xjf ${srcdir}/$_tarbz2
+ ln -s msp430-gcc-8.2.0.52_linux32 $pkgdir$_install_dir/mspgcc
fi
+ msg "Unzipping headers..."
+ unzip -qx ${srcdir}/$_zip
+ msg "Moving headers to their place..."
+ mv ${srcdir}/msp430-gcc-support-files/include/* $pkgdir$_install_dir/mspgcc/include
+ rm -rf $pkgdir$_install_dir/msp430-gcc-support-files
msg "Fixing directory permissions..."
find $pkgdir$_install_dir -type d -exec chmod a+x {} \;
mkdir -p $pkgdir$_install_dir/msp430-elf/lib
msg "Moving linker scripts to their place..."
- mv $pkgdir$_install_dir/include/*.ld $pkgdir$_install_dir/msp430-elf/lib
- mkdir -p $pkgdir$_install_dir/msp430-elf/include
- msg "Moving header files to their place..."
- mv $pkgdir$_install_dir/include/*.h $pkgdir$_install_dir/msp430-elf/include
- msg "Copying devices.csv to msp430-elf/include..."
- cp $pkgdir$_install_dir/include/*.csv $pkgdir$_install_dir/msp430-elf/include
+ mv $pkgdir$_install_dir/mspgcc/include/*.ld $pkgdir$_install_dir/mspgcc/msp430-elf/lib
+# mkdir -p $pkgdir$_install_dir/msp430-elf/include
+# msg "Moving header files to their place..."
+# mv $pkgdir$_install_dir/include/*.h $pkgdir$_install_dir/msp430-elf/include
+# msg "Copying devices.csv to msp430-elf/include..."
+# cp $pkgdir$_install_dir/include/*.csv $pkgdir$_install_dir/msp430-elf/include
install -Dm755 "${srcdir}/${pkgname}.sh" "${pkgdir}/etc/profile.d/${pkgname}.sh"
}