summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Ivanov2015-06-23 10:28:53 +0200
committerPeter Ivanov2015-06-23 10:28:53 +0200
commitc854875029ec17b48c451619c8c0aaaed2102d49 (patch)
tree4f205f4eaa305755d874fb057295ee060011f9b1
downloadaur-c854875029ec17b48c451619c8c0aaaed2102d49.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD38
-rw-r--r--mspgcc-ti.install12
-rwxr-xr-xmspgcc-ti.sh1
4 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8dfdaf04f078
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = mspgcc-ti
+ pkgdesc = GNU toolchain (as, gcc, g++, ld, gdb) for the TI MSP430 processor
+ pkgver = 3.02.03.00
+ pkgrel = 3
+ url = http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/latest/index_FDS.html
+ install = mspgcc-ti.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = elfutils
+ depends = libmpc
+ depends = zlib
+ options = !strip
+ options = !emptydirs
+ options = !libtool
+ options = staticlibs
+ options = !upx
+ source = http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/3_02_03_00/exports/msp430-gcc-full-linux-installer-3.2.3.0.run
+ source = mspgcc-ti.sh
+ sha1sums = 9dc0915a2c866871080c2e5134b2e5ab40f152ce
+ sha1sums = a4a81f1b041bf39c3f9c75d94c22d149d1ceee9e
+
+pkgname = mspgcc-ti
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..316f0b37a7ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Peter Ivanov <ivanovp@gmail.com>
+
+pkgname=mspgcc-ti
+pkgver=3.02.03.00
+pkgrel=3
+pkgdesc="GNU toolchain (as, gcc, g++, ld, gdb) for the TI MSP430 processor"
+arch=('i686' 'x86_64')
+url="http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/latest/index_FDS.html"
+license=('GPL')
+depends=('elfutils' 'libmpc' 'zlib')
+[ $CARCH = x86_64 ] && depends+=('lib32-gcc-libs' 'lib32-glibc' 'lib32-libstdc++5' 'lib32-zlib')
+options=(!strip !emptydirs !libtool staticlibs !upx)
+PKGEXT=".pkg.tar"
+install=mspgcc-ti.install
+_installer=msp430-gcc-full-linux-installer-3.2.3.0.run
+source=("http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/3_02_03_00/exports/$_installer" "${pkgname}.sh")
+sha1sums=('9dc0915a2c866871080c2e5134b2e5ab40f152ce'
+ 'a4a81f1b041bf39c3f9c75d94c22d149d1ceee9e')
+_install_dir=/opt/ti/mspgcc
+
+build() {
+ chmod +x $_installer
+}
+
+package() {
+ msg "Running TI's installer..."
+ ${srcdir}/$_installer --mode unattended --prefix $pkgdir$_install_dir
+ mkdir -p $pkgdir$_install_dir/msp430-elf/lib
+ msg "Moving linker scripts to their place..."
+ mv $pkgdir$_install_dir/include/*.ld $pkgdir$_install_dir/msp430-elf/lib
+ mkdir -p $pkgdir$_install_dir/msp430-elf/include
+ msg "Moving header files to their place..."
+ mv $pkgdir$_install_dir/include/*.h $pkgdir$_install_dir/msp430-elf/include
+
+ install -Dm755 "${srcdir}/${pkgname}.sh" "${pkgdir}/etc/profile.d/${pkgname}.sh"
+}
+
+# vim:set sts=2 ts=2 sw=2 et:
diff --git a/mspgcc-ti.install b/mspgcc-ti.install
new file mode 100644
index 000000000000..bde2d4610485
--- /dev/null
+++ b/mspgcc-ti.install
@@ -0,0 +1,12 @@
+post_install() {
+ echo "
+Add /opt/ti/mspgcc/bin to your PATH!
+
+Before using MSPGCC you have to agree with the LICENSE at:
+/opt/ti/mspgcc/License.txt
+"
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/mspgcc-ti.sh b/mspgcc-ti.sh
new file mode 100755
index 000000000000..070bc8597668
--- /dev/null
+++ b/mspgcc-ti.sh
@@ -0,0 +1 @@
+export PATH=$PATH:/opt/ti/mspgcc/bin