summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Ivanov2020-07-13 08:12:40 +0200
committerPeter Ivanov2020-07-13 08:12:40 +0200
commitedaad460ebf86b297ca76f45b165703c91a25847 (patch)
tree95aeeffd4bf900da58e4c6d1108a01771938ea82
parent790695266f7b7b519b750de977c30ad4f90bfb55 (diff)
downloadaur-edaad460ebf86b297ca76f45b165703c91a25847.tar.gz
Updated to version 9.2.0.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
2 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e29d84719cc2..070f8b695a6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = mspgcc-ti
pkgdesc = GNU toolchain (as, gcc, g++, ld, gdb) for the TI MSP430 processor
- pkgver = 8.3.1.0
+ pkgver = 9.2.0.0
pkgrel = 1
- url = http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/latest/index_FDS.html
+ url = https://www.ti.com/tool/download/MSP430-GCC-OPENSOURCE
install = mspgcc-ti.install
arch = i686
arch = x86_64
@@ -15,13 +15,13 @@ pkgbase = mspgcc-ti
options = !libtool
options = staticlibs
source = mspgcc-ti.sh
- source = http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/latest/exports/msp430-gcc-support-files-1.208.zip
+ source = http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/9_2_0_0/export/msp430-gcc-support-files-1.210.zip
sha1sums = a4a81f1b041bf39c3f9c75d94c22d149d1ceee9e
- sha1sums = 4b266c9bb4c61eb16bc95d85a12a3a7bd428f1cc
- source_i686 = http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/8_3_1_0/export/msp430-gcc-8.3.1.25_linux32.tar.bz2
- sha1sums_i686 = a20bd0abfc7c6b5e7eef2b6ef60eb6bc2d84373c
- source_x86_64 = http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/8_3_1_0/export/msp430-gcc-8.3.1.25_linux64.tar.bz2
- sha1sums_x86_64 = 63bafc3cd8562adf44ec6c1d43dc8c47030379a1
+ sha1sums = 9ca58e925f4c3cdbed46436dc4e0c43b2506632a
+ source_i686 = http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/9_2_0_0/export/msp430-gcc-9.2.0.50_linux32.tar.bz2
+ sha1sums_i686 = f133287193b3d9a71dd04e3f2dbe734ff267c0ec
+ source_x86_64 = http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/9_2_0_0/export/msp430-gcc-9.2.0.50_linux64.tar.bz2
+ sha1sums_x86_64 = eed9f3e8b0c11021f841b16de21912c3f0bcc35b
pkgname = mspgcc-ti
diff --git a/PKGBUILD b/PKGBUILD
index 9969f8754d29..ef69a882cc57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,29 @@
# Maintainer: Peter Ivanov <ivanovp@gmail.com>
pkgname=mspgcc-ti
-pkgver=8.3.1.0
+pkgver=9.2.0.0
pkgrel=1
pkgdesc="GNU toolchain (as, gcc, g++, ld, gdb) for the TI MSP430 processor"
arch=('i686' 'x86_64')
-url="http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/latest/index_FDS.html"
+url="https://www.ti.com/tool/download/MSP430-GCC-OPENSOURCE"
license=('GPL')
depends=('elfutils' 'libmpc' 'zlib')
options=(!strip !emptydirs !libtool staticlibs)
PKGEXT=".pkg.tar"
install=mspgcc-ti.install
#http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/latest/exports/msp430-gcc-8.2.0.52_linux64.tar.bz2
-_name=msp430-gcc-8.3.1.25
+_name=msp430-gcc-9.2.0.50
_tarbz2=${_name}_linux32.tar.bz2
_tarbz2_x64=${_name}_linux64.tar.bz2
-_zip=msp430-gcc-support-files-1.208.zip
+_zip=msp430-gcc-support-files-1.210.zip
source=("${pkgname}.sh"
- "http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/latest/exports/$_zip")
-source_i686=("http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/8_3_1_0/export/$_tarbz2")
-source_x86_64=("http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/8_3_1_0/export/$_tarbz2_x64")
+ "http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/9_2_0_0/export/$_zip")
+source_i686=("http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/9_2_0_0/export/$_tarbz2")
+source_x86_64=("http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSPGCC/9_2_0_0/export/$_tarbz2_x64")
sha1sums=('a4a81f1b041bf39c3f9c75d94c22d149d1ceee9e'
- '4b266c9bb4c61eb16bc95d85a12a3a7bd428f1cc')
-sha1sums_i686=('a20bd0abfc7c6b5e7eef2b6ef60eb6bc2d84373c')
-sha1sums_x86_64=('63bafc3cd8562adf44ec6c1d43dc8c47030379a1')
+ '9ca58e925f4c3cdbed46436dc4e0c43b2506632a')
+sha1sums_i686=('f133287193b3d9a71dd04e3f2dbe734ff267c0ec')
+sha1sums_x86_64=('eed9f3e8b0c11021f841b16de21912c3f0bcc35b')
_install_dir=/opt/ti
package() {