summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBZHDeveloper2018-05-14 17:12:42 +0200
committerBZHDeveloper2018-05-14 17:12:42 +0200
commitf80aae88441f3f5ade244058ea9187be545f7c3e (patch)
treeebd73d012ff657e36ed7ea8d34c23decb4ff7aed
downloadaur-f80aae88441f3f5ade244058ea9187be545f7c3e.tar.gz
First commit : update git repository.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
-rw-r--r--depmod.install15
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f1870444526
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mt7610u_wifi_sta-alt
+ pkgdesc = Kernel module for MediaTek MT7610U chipset featured in TP-Link Archer T2U and T2UH, TP-Link TL-WDN5200, ASUS USB-AC50, ASUS USB-AC51, Comcast Xfinity KXW02AAA, D-Link DWA-171 rev B1 and more
+ pkgver = 1
+ pkgrel = 3
+ url = https://github.com/BZHDeveloper/mt7610u_wifi_sta_v3002_dpo_20130916
+ install = depmod.install
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = linux-headers
+ depends = linux
+ conflicts = mt7610u_wifi_sta
+ source = mt7610u_wifi_sta::git+https://github.com/BZHDeveloper/mt7610u_wifi_sta_v3002_dpo_20130916.git
+ md5sums = SKIP
+
+pkgname = mt7610u_wifi_sta-alt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93c5b90a1519
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Yannick Inizan <inizan[dot]yannick[at]gmail[dot}com>
+
+pkgname=mt7610u_wifi_sta-alt
+pkgver=1
+pkgrel=3
+# To get an overview of witch WiFi dongle has this chipset refer to https://wikidevi.com/wiki/MediaTek_MT7610U
+pkgdesc="Kernel module for MediaTek MT7610U chipset featured in TP-Link Archer T2U and T2UH, TP-Link TL-WDN5200, ASUS USB-AC50, ASUS USB-AC51, Comcast Xfinity KXW02AAA, D-Link DWA-171 rev B1 and more"
+arch=('any')
+license=('GPL2')
+url="https://github.com/BZHDeveloper/mt7610u_wifi_sta_v3002_dpo_20130916"
+conflicts=('mt7610u_wifi_sta')
+depends=('linux')
+makedepends=('git' 'linux-headers')
+install="depmod.install"
+source=("mt7610u_wifi_sta"::"git+https://github.com/BZHDeveloper/mt7610u_wifi_sta_v3002_dpo_20130916.git")
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ major=$(uname -r | cut -d'.' -f1)
+ minor=$(uname -r | cut -d'.' -f2)
+ linuxver="${major}.${minor}"
+ if [ $(echo "${linuxver} < 4.14" | bc) -eq 1 ]; then
+ linuxver="4.10"
+ elif [ $(echo "${linuxver} >= 4.15" | bc) -eq 1 ]; then
+ linuxver="4.15"
+ fi
+ git checkout "linux-${linuxver}"
+ make -C "${srcdir}/${pkgname}"
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ mkdir -p "${pkgdir}/etc/Wireless/RT2870STA"
+ mkdir -p "${pkgdir}/usr/lib/modules/$(uname -r)/kernel/drivers/net/wireless/os/linux"
+ install -m 644 -t "${pkgdir}/etc/Wireless/RT2870STA" RT2870STA.dat
+ install -m 644 -t "${pkgdir}/usr/lib/modules/$(uname -r)/kernel/drivers/net/wireless/os/linux" os/linux/*.ko
+}
diff --git a/depmod.install b/depmod.install
new file mode 100644
index 000000000000..fb8d863ea3cf
--- /dev/null
+++ b/depmod.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -e "\e[34;1m==>\e[39;1m Running depmod... \e[0m"
+ depmod
+ echo -e "\e[34;1m==>\e[39;1m NOTE: Module name is mt7650u_sta \e[0m"
+}
+
+post_upgrade() {
+ echo -e "\e[34;1m==>\e[39;1m Running depmod... \e[0m"
+ depmod
+}
+
+post_remove() {
+ echo -e "\e[34;1m==>\e[39;1m Running depmod... \e[0m"
+ depmod
+}