summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBZHDeveloper2018-06-04 01:36:35 +0200
committerBZHDeveloper2018-06-04 01:36:35 +0200
commitfa188cc05e0fc5225c87a31b296c00096252ffbd (patch)
treed77d5000f3568850d0d25b653f566cabf48811e3
parente911d14a7f34b2d86064acf0559d7768a92e8b84 (diff)
downloadaur-fa188cc05e0fc5225c87a31b296c00096252ffbd.tar.gz
Use gitlab repository as source.
-rw-r--r--PKGBUILD25
1 files changed, 9 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3b686c49b5d1..0756e6e255e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Yannick Inizan <inizan[dot]yannick[at]gmail[dot}com>
+# Maintainer: Yannick Inizan <inizan[dot]yannick[at]gmail[dot]com>
+# Based on the PKGBUILD created by Ivan Agarkov <ivan[dot]agarkov[at]gmail[dot]com>
pkgname=mt7610u_wifi_sta-alt
pkgver=2
@@ -7,32 +8,24 @@ pkgrel=3
pkgdesc="Kernel module for MediaTek MT7610U chipset featured in TP-Link Archer T2U and T2UH, TP-Link TL-WDN5200, ASUS USB-AC50, ASUS USB-AC51, Comcast Xfinity KXW02AAA, D-Link DWA-171 rev B1 and more"
arch=('any')
license=('GPL2')
-url="https://github.com/BZHDeveloper/mt7610u_wifi_sta_v3002_dpo_20130916"
+url="https://gitlab.com/BZHDeveloper/mt7610u_wifi_sta_v3002_dpo_20130916"
conflicts=('mt7610u_wifi_sta')
+replaces=('mt7610u_wifi_sta')
depends=('linux')
makedepends=('git' 'linux-headers')
install="depmod.install"
-source=("mt7610u_wifi_sta-alt"::"git+https://github.com/BZHDeveloper/mt7610u_wifi_sta_v3002_dpo_20130916.git")
+source=("mt7610u_wifi_sta-alt"::"git+https://gitlab.com/BZHDeveloper/mt7610u_wifi_sta_v3002_dpo_20130916.git")
md5sums=('SKIP')
build() {
cd "${srcdir}/${pkgname}"
- major=$(uname -r | cut -d'.' -f1)
- minor=$(uname -r | cut -d'.' -f2)
- linuxver="${major}.${minor}"
- if [ $(echo "${linuxver} < 4.14" | bc) -eq 1 ]; then
- linuxver="4.10"
- elif [ $(echo "${linuxver} >= 4.15" | bc) -eq 1 ]; then
- linuxver="4.15"
- fi
- git checkout "linux-${linuxver}"
- make -C "${srcdir}/${pkgname}"
+ make -C "${srcdir}/${pkgname}"
}
package() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/${pkgname}"
mkdir -p "${pkgdir}/etc/Wireless/RT2870STA"
mkdir -p "${pkgdir}/usr/lib/modules/$(uname -r)/kernel/drivers/net/wireless/os/linux"
- install -m 644 -t "${pkgdir}/etc/Wireless/RT2870STA" RT2870STA.dat
- install -m 644 -t "${pkgdir}/usr/lib/modules/$(uname -r)/kernel/drivers/net/wireless/os/linux" os/linux/*.ko
+ install -m 644 -t "${pkgdir}/etc/Wireless/RT2870STA" RT2870STA.dat
+ install -m 644 -t "${pkgdir}/usr/lib/modules/$(uname -r)/kernel/drivers/net/wireless/os/linux" os/linux/*.ko
}