summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDylan Delgado2023-02-07 16:06:36 -0500
committerDylan Delgado2023-02-07 16:06:36 -0500
commit2ae229b6fe29d146a43fd27e7dc5c68fa1a71798 (patch)
treeb0a27da121102b227ac62e04191fd290d0731612
parent4bd37be98f3be2993ed385af1451fa80961bdccc (diff)
downloadaur-2ae229b6fe29d146a43fd27e7dc5c68fa1a71798.tar.gz
Update to latest revision, add linker flag
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8151e5eec1d..049d7f7b4713 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mtsieve
pkgdesc = Library for sieving various types of numbers
- pkgver = 2.3.8.r229
+ pkgver = 2.4.2.r257
pkgrel = 1
url = https://sourceforge.net/projects/mtsieve/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 880e68428b00..3010433dd962 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
#Maintainer: Dylan Delgado <dylan1496@live.com>
pkgname=mtsieve
-pkgver=2.3.8.r229
+pkgver=2.4.2.r257
pkgrel=1
pkgdesc='Library for sieving various types of numbers'
url='https://sourceforge.net/projects/mtsieve/'
@@ -24,6 +24,7 @@ prepare() {
-e 's/^CPPFLAGS =/CPPFLAGS +=/' \
-e "/^SVN_VERSION :=/s/=.*/= r${_pkgrev}/" \
-i makefile
+ sed '30 c\LD_FLAGS=-z noexecstack' -i makefile
cd core
sed '11 c\#include <cstddef>' -i MpArithVector.h
}
@@ -31,6 +32,7 @@ prepare() {
build() {
cd "${srcdir}/${pkgname}-svn"
CPPFLAGS+=' -march=native'
+ LD_FLAGS+=' -z noexecstack'
make
}