summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzombielinux2019-11-26 10:16:33 -0500
committerzombielinux2019-11-26 10:16:33 -0500
commit61d53e9ce2b24f415c616f203db0ca11666d9d17 (patch)
treef97f68ecebda2d79d1e7a7dfd6d8c8c1bb5bc3ec
downloadaur-mtx-git.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c684cf943be
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mtx-git
+ pkgdesc = Tools used to view information about, and to control, Media Changer devices such as Tape and DVD/CD libraries.
+ pkgver = 20191126
+ pkgrel = 1
+ url = https://github.com/zombielinux/MTX
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ provides = mtx
+ conflicts = mtx
+ source = git+https://github.com/zombielinux/MTX.git
+ md5sums = SKIP
+
+pkgname = mtx-git
+
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c06e232e5f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: William Sutton <will at sutton-family dot org>
+
+pkgname=mtx-git
+_pkgname=MTX
+pkgver=20191126
+pkgrel=1
+pkgdesc="Tools used to view information about, and to control, Media Changer devices such as Tape and DVD/CD libraries."
+arch=('i686' 'x86_64')
+url="https://github.com/zombielinux/MTX"
+license=('GPL2')
+provides=('mtx')
+conflicts=('mtx')
+makedepends=('git')
+source=(git+https://github.com/zombielinux/MTX.git)
+md5sums=('SKIP')
+
+#pkgver() {
+# cd "${pkgname}"
+# local ver="$(svnversion)"
+# printf "r%s" "${ver//[[:alpha:]]}"
+#}
+
+build() {
+ cd "${srcdir}/${_pkgname}/mtx"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}/mtx"
+ make prefix="$pkgdir/usr" sbindir="$pkgdir/usr/bin" mandir="$pkgdir/usr/share/man" install
+}
+