summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2020-06-29 23:28:10 +0200
committerFabioLolix2020-06-29 23:28:10 +0200
commitf32a657d39723cf0f78050e5051b1c1e1c855826 (patch)
tree239a382153497d17cd55b118ff10fafc7064e564
downloadaur-mudita24-git.tar.gz
svn to git revision
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD39
-rw-r--r--mudita24.desktop9
-rw-r--r--mudita24.pngbin0 -> 1055 bytes
4 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c53ac482eada
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = mudita24-git
+ pkgdesc = Improved Control Panel for Ice1712 Audio Cards
+ pkgver = r16.e38b1a3
+ pkgrel = 1
+ url = https://github.com/NielsMayer/mudita24
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ depends = alsa-lib
+ depends = gtk2
+ source = git+https://github.com/NielsMayer/mudita24
+ source = mudita24.desktop
+ source = mudita24.png
+ sha256sums = SKIP
+ sha256sums = 4fdfcf2d92ee0424fa2af5e06cf21fb07ac5bc9938db224a38a4687cb5c44637
+ sha256sums = a659ff56346e3d11bd0c386efd55b183c5e07c9ae8e03e5de15caf6c1be09513
+
+pkgname = mudita24-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06b667de538c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Contributor: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Ricky Sheaves <ricky[at]westdowneast[dot]com>
+
+pkgname=mudita24-git
+pkgver=r16.e38b1a3
+pkgrel=1
+pkgdesc="Improved Control Panel for Ice1712 Audio Cards"
+arch=(i686 x86_64)
+url="https://github.com/NielsMayer/mudita24"
+license=(GPL2)
+depends=(alsa-lib gtk2)
+makedepends=(git cmake)
+source=("git+https://github.com/NielsMayer/mudita24"
+ mudita24.desktop
+ mudita24.png)
+sha256sums=('SKIP'
+ '4fdfcf2d92ee0424fa2af5e06cf21fb07ac5bc9938db224a38a4687cb5c44637'
+ 'a659ff56346e3d11bd0c386efd55b183c5e07c9ae8e03e5de15caf6c1be09513')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${pkgname%-git}/${pkgname%-git}"
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd "${pkgname%-git}/${pkgname%-git}"
+ make DESTDIR="${pkgdir}" install
+
+ install -D -m644 "${srcdir}/mudita24.desktop" "${pkgdir}/usr/share/applications/mudita24.desktop"
+ install -D -m644 "${srcdir}/mudita24.png" "${pkgdir}/usr/share/pixmaps/mudita24.png"
+
+ install -D -m644 COPYING "$pkgdir/usr/share/licenses/mudita24/COPYING"
+}
diff --git a/mudita24.desktop b/mudita24.desktop
new file mode 100644
index 000000000000..a22ea98d5bd4
--- /dev/null
+++ b/mudita24.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Mudita24
+GenericName=Mudita24
+Comment=Control Panel for Ice1712 Audio Cards.
+Exec=mudita24
+Icon=/usr/share/pixmaps/mudita24.png
+Terminal=false
+Type=Application
+Categories=Application;AudioVideo;Audio;X-Sound; \ No newline at end of file
diff --git a/mudita24.png b/mudita24.png
new file mode 100644
index 000000000000..4126a80af3e2
--- /dev/null
+++ b/mudita24.png
Binary files differ