aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTurboCheetah2022-02-25 08:58:12 -0500
committerTurboCheetah2022-02-25 08:58:12 -0500
commita58dcabb0502c42d6d165d0d0fc64b06d0af7b82 (patch)
treee39348ed7cf2385e34810289dd754a9ac12b9d8f
downloadaur-mullvad-runit.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD15
-rw-r--r--README.md2
-rw-r--r--run3
5 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f4a67aa7fafe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = mullvad-runit
+ pkgdesc = mullvad runit service
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/TurboCheetah/mullvad-runit
+ arch = any
+ license = MIT
+ depends = runit
+ source = run
+ sha256sums = 5175b99d7d64764a82928c7c13a4b803f2ff24c41a1bc174abc547258ff95629
+
+pkgname = mullvad-runit
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..e96855ea9413
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2022 Turbo
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..485b337ac9f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,15 @@
+# Maintainer: Turbo <dev@turbo.ooo>
+pkgname=mullvad-runit
+pkgver=1.0
+pkgrel=1
+pkgdesc="mullvad runit service"
+arch=('any')
+url='https://github.com/TurboCheetah/mullvad-runit'
+license=('MIT')
+depends=('runit')
+source=("run")
+sha256sums=("5175b99d7d64764a82928c7c13a4b803f2ff24c41a1bc174abc547258ff95629")
+
+package() {
+ install -Dm755 ${srcdir}/run "$pkgdir"/etc/runit/sv/mullvad/run
+} \ No newline at end of file
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..20b715aa92c6
--- /dev/null
+++ b/README.md
@@ -0,0 +1,2 @@
+# mullvad-runit
+Simple runit service for Mullvad
diff --git a/run b/run
new file mode 100644
index 000000000000..6fa7030d5445
--- /dev/null
+++ b/run
@@ -0,0 +1,3 @@
+#!/bin/sh
+sv check NetworkManager >/dev/null || exit 1
+exec /opt/Mullvad\ VPN/resources/mullvad-daemon