summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2025-04-21 12:15:09 -0600
committerMark Wagie2025-04-21 12:15:09 -0600
commit1c26c40ba2ea0ad472d0a06af7df55715ca5ca4f (patch)
treed3e4730c7089fbc827bde5eca83dcf925fd6e295
parent3b87cebfc549ab84d1e027d64c17d64a6db49f8e (diff)
downloadaur-mullvad-vpn-bin.tar.gz
Fix syntax error in Apparmor profile
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD11
-rw-r--r--apparmor_mullvad8
4 files changed, 20 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84c40fad4dfa..b6e45f36f290 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mullvad-vpn-bin
pkgdesc = The Mullvad VPN client app for desktop
pkgver = 2025.5
- pkgrel = 1
+ pkgrel = 2
url = https://www.mullvad.net
install = mullvad-vpn.install
arch = x86_64
@@ -17,8 +17,10 @@ pkgbase = mullvad-vpn-bin
provides = mullvad-vpn
conflicts = mullvad-vpn
source = mullvad-vpn.sh
+ source = apparmor_mullvad
validpgpkeys = A1198702FC3E0A09A9AE5B75D5A1D4F266DE8DDF
sha256sums = a59c29f07b4eab9af56f0e8be42bae0d83726f5185e88de0c5a48f4098c3c0a4
+ sha256sums = a7b99f7acbb7f99c6ab8ecf5bb674310294c29a561d9bd7c531508841942cab3
source_x86_64 = https://github.com/mullvad/mullvadvpn-app/releases/download/2025.5/MullvadVPN-2025.5_amd64.deb
source_x86_64 = https://github.com/mullvad/mullvadvpn-app/releases/download/2025.5/MullvadVPN-2025.5_amd64.deb.asc
sha256sums_x86_64 = 9fa08d6e21637aa3a04fbd97d88282382a7186fef27d56f5e5d8fccb5f7f5e5d
diff --git a/.gitignore b/.gitignore
index 33ef08ea9b23..cbe4bd562d7a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -9,3 +9,4 @@
!LICENSE
!mullvad-vpn.install
!mullvad-vpn.sh
+!apparmor_mullvad
diff --git a/PKGBUILD b/PKGBUILD
index d4b91f6ac72d..eaae0504cf0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: alicewww <almw at protonmail dot com>
pkgname=mullvad-vpn-bin
pkgver=2025.5
-pkgrel=1
+pkgrel=2
pkgdesc="The Mullvad VPN client app for desktop"
arch=('x86_64' 'aarch64')
url="https://www.mullvad.net"
@@ -20,10 +20,12 @@ optdepends=('libappindicator-gtk3: tray icon')
provides=('mullvad-vpn')
conflicts=('mullvad-vpn')
install='mullvad-vpn.install'
-source=('mullvad-vpn.sh')
+source=('mullvad-vpn.sh'
+ 'apparmor_mullvad')
source_x86_64=("https://github.com/mullvad/mullvadvpn-app/releases/download/$pkgver/MullvadVPN-${pkgver}_amd64.deb"{,.asc})
source_aarch64=("https://github.com/mullvad/mullvadvpn-app/releases/download/$pkgver/MullvadVPN-${pkgver}_arm64.deb"{,.asc})
-sha256sums=('a59c29f07b4eab9af56f0e8be42bae0d83726f5185e88de0c5a48f4098c3c0a4')
+sha256sums=('a59c29f07b4eab9af56f0e8be42bae0d83726f5185e88de0c5a48f4098c3c0a4'
+ 'a7b99f7acbb7f99c6ab8ecf5bb674310294c29a561d9bd7c531508841942cab3')
sha256sums_x86_64=('9fa08d6e21637aa3a04fbd97d88282382a7186fef27d56f5e5d8fccb5f7f5e5d'
'SKIP')
sha256sums_aarch64=('fa0dd44e22b23497bc8bccc6c920a8483de5d4aae5ddf4af8f9a248f6745db35'
@@ -37,6 +39,9 @@ package() {
# Link to the GUI binary
install -m755 "$srcdir/mullvad-vpn.sh" "$pkgdir/usr/bin/mullvad-vpn"
+ # Fix syntax error in Apparmor profile
+ install -Dm644 "$srcdir/apparmor_mullvad" -t "$pkgdir/opt/Mullvad VPN/"
+
# Symlink apparmor profile to allow Electron sandbox to work
install -d "$pkgdir/etc/apparmor.d"
ln -s /opt/Mullvad\ VPN/resources/apparmor_mullvad "$pkgdir/etc/apparmor.d/mullvad"
diff --git a/apparmor_mullvad b/apparmor_mullvad
new file mode 100644
index 000000000000..8b83a07954a6
--- /dev/null
+++ b/apparmor_mullvad
@@ -0,0 +1,8 @@
+abi <abi/4.0>,
+include <tunables/global>
+
+profile mullvad "/opt/Mullvad VPN/mullvad-gui" flags=(unconfined) {
+ userns,
+ # Site-specific additions and overrides. See local/README for details.
+ include if exists <local/mullvad>
+}