summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-10-14 11:47:30 -0600
committerMark Wagie2022-10-14 11:47:30 -0600
commit178064b46a43a2153d805ceac5d4145016f955d8 (patch)
treecdb4461903dd8579cc6a27f59b45d944ff6f6c40
parent37898a0f12289511f0e9dfe48d74d7c54289b97c (diff)
downloadaur-178064b46a43a2153d805ceac5d4145016f955d8.tar.gz
2022.5
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD31
-rw-r--r--mullvad-vpn.install19
3 files changed, 30 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 808621ea2636..1f08a9ce8993 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = mullvad-vpn-cli
pkgdesc = The Mullvad VPN CLI client
- pkgver = 2022.4
- pkgrel = 2
+ pkgver = 2022.5
+ pkgrel = 1
url = https://www.mullvad.net
install = mullvad-vpn.install
arch = x86_64
+ arch = aarch64
license = GPL3
makedepends = cargo
makedepends = git
@@ -14,8 +15,8 @@ pkgbase = mullvad-vpn-cli
provides = mullvad-vpn
conflicts = mullvad-vpn
options = !lto
- source = git+https://github.com/mullvad/mullvadvpn-app.git#commit=06c847a7a7d72a148bd5dba0a44860eb1b3aa182?signed
- source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=b63c5c8c7977963aeb585b6ddd4537dffe2aeeec?signed
+ source = git+https://github.com/mullvad/mullvadvpn-app.git#commit=5bcd2533633d76b1deaf5875b24a2c83bec6fc49?signed
+ source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=f6dca66645c82501a330416ad39c7e63bcdae57d?signed
validpgpkeys = EA0A77BF9E115615FC3BD8BC7653B940E494FE87
validpgpkeys = 8339C7D2942EB854E3F27CE5AEE9DECFD582E984
validpgpkeys = 4B986EF5222BA1B810230C602F391DE6B00D619C
diff --git a/PKGBUILD b/PKGBUILD
index 74b238327841..e180caf8d79b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
# Contributor: John Andrews <theunderdog09 at gmail dot com>
# Contributor: Timo Kramer <fw minus aur at timokramer dot de>
pkgname=mullvad-vpn-cli
-pkgver=2022.4
-pkgrel=2
+pkgver=2022.5
+pkgrel=1
pkgdesc="The Mullvad VPN CLI client"
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://www.mullvad.net"
license=('GPL3')
depends=('dbus' 'iputils')
@@ -14,8 +14,8 @@ provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
options=('!lto')
install="${pkgname%-*}.install"
-_tag=06c847a7a7d72a148bd5dba0a44860eb1b3aa182 # tags/2022.4^0
-_commit=b63c5c8c7977963aeb585b6ddd4537dffe2aeeec
+_tag=5bcd2533633d76b1deaf5875b24a2c83bec6fc49 # tags/2022.5^0
+_commit=f6dca66645c82501a330416ad39c7e63bcdae57d
source=("git+https://github.com/mullvad/mullvadvpn-app.git#commit=${_tag}?signed"
"git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=${_commit}?signed")
sha256sums=('SKIP'
@@ -45,7 +45,6 @@ prepare() {
pushd wireguard/libwg
export GOPATH="$srcdir/gopath"
mkdir -p "../../build/lib/$CARCH-unknown-linux-gnu"
-
go mod download -x
popd
}
@@ -53,9 +52,8 @@ prepare() {
build() {
cd "$srcdir/mullvadvpn-app"
local RUSTC_VERSION=$(rustc --version)
- source env.sh ""
- echo "Building Mullvad VPN CLI $pkgver..."
+ echo "Building Mullvad VPN ${PRODUCT_VERSION}..."
echo "Building wireguard-go..."
pushd wireguard/libwg
@@ -71,14 +69,12 @@ build() {
# Clean module cache for makepkg -C
go clean -modcache
- export MULLVAD_ADD_MANIFEST="1"
-
echo "Building Rust code in release mode using ${RUSTC_VERSION}..."
-
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
cargo build --frozen --release
+ echo "Preparing for packaging Mullvad VPN ${PRODUCT_VERSION}..."
mkdir -p dist-assets/shell-completions
for sh in bash zsh fish; do
echo "Generating shell completion script for ${sh}..."
@@ -86,7 +82,7 @@ build() {
dist-assets/shell-completions/
done
- echo "Updating relay list..."
+ echo "Updating relays.json..."
cargo run --bin relay_list --frozen --release > dist-assets/relays.json
}
@@ -94,10 +90,10 @@ package() {
cd "$srcdir/mullvadvpn-app"
# Install binaries
- install -Dm755 target/release/mullvad{-daemon,-problem-report,-setup} -t \
+ install -Dm755 target/release/mullvad{-problem-report,-setup} -t \
"$pkgdir/opt/Mullvad VPN/resources/"
- install -Dm755 target/release/{mullvad,mullvad-exclude} -t \
+ install -Dm755 target/release/{mullvad,mullvad{-daemon,-exclude}} -t \
"$pkgdir/usr/bin/"
install -m644 target/release/libtalpid_openvpn_plugin.so -t \
@@ -107,14 +103,13 @@ package() {
"$pkgdir/opt/Mullvad VPN/resources/"
# Link to the problem report binary
- ln -s "/opt/Mullvad VPN/resources/mullvad-problem-report" \
- "$pkgdir/usr/bin/mullvad-problem-report"
+ ln -s "/opt/Mullvad VPN/resources/mullvad-problem-report" "$pkgdir/usr/bin/"
# Install relay list
install -Dm644 dist-assets/relays.json -t "$pkgdir/opt/Mullvad VPN/resources/"
- # Install service
- install -Dm644 dist-assets/linux/mullvad-daemon.service -t \
+ # Install services
+ install -Dm644 dist-assets/linux/{mullvad{-daemon,-early-boot-blocking}} -t \
"$pkgdir/usr/lib/systemd/system/"
# Install completions
diff --git a/mullvad-vpn.install b/mullvad-vpn.install
index 2f602f6df88c..2183aa37b439 100644
--- a/mullvad-vpn.install
+++ b/mullvad-vpn.install
@@ -1,8 +1,10 @@
pre_install() {
if systemctl status mullvad-daemon &> /dev/null; then
echo 'Stopping & disabling Mullvad VPN daemon...'
- /opt/Mullvad VPN/resources/mullvad-setup prepare-restart || true
+ /opt/Mullvad\ VPN/resources/mullvad-setup prepare-restart || true
systemctl disable --now mullvad-daemon
+ echo 'Disabling Mullvad early boot blocking service...'
+ systemctl disable mullvad-early-boot-blocking.service || true
cp /var/log/mullvad-vpn/daemon.log /var/log/mullvad-vpn/old-install-daemon.log \
|| echo "Failed to copy old daemon log"
fi
@@ -16,6 +18,7 @@ post_install() {
echo 'Enabling Mullvad VPN daemon...'
systemctl enable --now mullvad-daemon
+ systemctl enable mullvad-early-boot-blocking
}
pre_upgrade() {
@@ -26,18 +29,20 @@ post_upgrade() {
echo 'Starting & enabling Mullvad VPN daemon...'
systemctl daemon-reload
systemctl enable --now mullvad-daemon
+ echo 'Enabling Mullvad early boot blocking service...'
+ systemctl enable mullvad-early-boot-blocking
chmod u+s "/usr/bin/mullvad-exclude"
}
pre_remove() {
- # the user might've disabled or stopped the service themselves already
- echo 'Making sure the Mullvad VPN daemon is stopped & disabled...'
- systemctl stop mullvad-daemon || true
- systemctl disable mullvad-daemon || true
+ # the user might've disabled or stopped the services themselves already
+ echo 'Making sure the services are stopped & disabled...'
+ systemctl disable --now mullvad-daemon || true
+ systemctl disable --now mullvad-early-boot-blocking.service || true
- /opt/Mullvad VPN/resources/mullvad-setup reset-firewall || echo "Failed to reset firewall"
- /opt/Mullvad VPN/resources/mullvad-setup remove-device || echo "Failed to remove device from account"
+ /opt/Mullvad\ VPN/resources/mullvad-setup reset-firewall || echo "Failed to reset firewall"
+ /opt/Mullvad\ VPN/resources/mullvad-setup remove-device || echo "Failed to remove device from account"
}
post_remove() {